06e3957c16
In addition: - Update 0001-user-exec-fix-usage-of-mcontext-structure-on-ARM-uCl.patch with new line numbers and file location. - Remove upstream 0002-memfd-fix-configure-test.patch - Add new options found in 2.12.0 in qemu.mk as disabled. - Remove --with-system-pixman as it's no longer optional. Tested with test-pkg: ./utils/test-pkg -p qemu -c configs/qemu_min_defconfig br-arm-full [1/6]: OK br-arm-cortex-a9-glibc [2/6]: OK br-arm-cortex-m4-full [3/6]: SKIPPED br-x86-64-musl [4/6]: OK br-arm-full-static [5/6]: OK armv5-ctng-linux-gnueabi [6/6]: OK 6 builds, 1 skipped, 0 build failed, 0 legal-info failed Signed-off-by: Adam Duskett <aduskett@gmail.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
36 lines
1.3 KiB
Diff
36 lines
1.3 KiB
Diff
From d3f1e7e9ff9aae3f770b0bcb9aa3c2f787f76a1b Mon Sep 17 00:00:00 2001
|
|
From: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
|
|
Date: Fri, 5 May 2017 09:07:15 +0200
|
|
Subject: [PATCH] user-exec: fix usage of mcontext structure on ARM/uClibc
|
|
|
|
user-exec.c has some conditional code to decide how to use the
|
|
mcontext structure. Unfortunately, since uClibc defines __GLIBC__, but
|
|
with old versions of __GLIBC__ and __GLIBC_MINOR__, an old code path
|
|
gets used, which doesn't apply to uClibc.
|
|
|
|
Fix this by excluding __UCLIBC__, which ensures we fall back to the
|
|
general case of using uc_mcontext.arm_pc, which works fine with
|
|
uClibc.
|
|
|
|
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
|
|
---
|
|
user-exec.c | 2 +-
|
|
1 file changed, 1 insertion(+), 1 deletion(-)
|
|
|
|
diff --git a/accel/tcg/user-exec.c b/accel/tcg/user-exec.c
|
|
index 6db0758..2b3d116 100644
|
|
--- a/accel/tcg/user-exec.c
|
|
+++ b/accel/tcg/user-exec.c
|
|
@@ -463,7 +463,7 @@ int cpu_signal_handler(int host_signum, void *pinfo,
|
|
|
|
#if defined(__NetBSD__)
|
|
pc = uc->uc_mcontext.__gregs[_REG_R15];
|
|
-#elif defined(__GLIBC__) && (__GLIBC__ < 2 || (__GLIBC__ == 2 && __GLIBC_MINOR__ <= 3))
|
|
+#elif defined(__GLIBC__) && !defined(__UCLIBC__) && (__GLIBC__ < 2 || (__GLIBC__ == 2 && __GLIBC_MINOR__ <= 3))
|
|
pc = uc->uc_mcontext.gregs[R15];
|
|
#else
|
|
pc = uc->uc_mcontext.arm_pc;
|
|
--
|
|
2.7.4
|
|
|