e360d763dd
Add patch to disable documentation through BUILD_DOC which is already passed by cmake-infrastructure Fixes: - http://autobuild.buildroot.org/results/f58a1d1a4ffdaf94fd0fcb4dbebe1e898f95638d Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
29 lines
765 B
Diff
29 lines
765 B
Diff
From 8038b6343466b9a58fd5ef5f13d3255ecbfce5aa Mon Sep 17 00:00:00 2001
|
|
From: Fabrice Fontaine <fontaine.fabrice@gmail.com>
|
|
Date: Thu, 31 Oct 2019 13:41:04 +0100
|
|
Subject: [PATCH] CMakeLists.txt: add BUILD_DOC option
|
|
|
|
Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
|
|
[Upstream status: https://github.com/skypjack/uvw/pull/165]
|
|
---
|
|
CMakeLists.txt | 3 ++-
|
|
1 file changed, 2 insertions(+), 1 deletion(-)
|
|
|
|
diff --git a/CMakeLists.txt b/CMakeLists.txt
|
|
index 9fc5538..da6a02d 100644
|
|
--- a/CMakeLists.txt
|
|
+++ b/CMakeLists.txt
|
|
@@ -62,7 +62,8 @@ find_package(Doxygen 1.8)
|
|
# Referenced directories and targets
|
|
#
|
|
|
|
-if(DOXYGEN_FOUND)
|
|
+option(BUILD_DOC "Build documentation" ON)
|
|
+if(BUILD_DOC AND DOXYGEN_FOUND)
|
|
add_subdirectory(docs)
|
|
endif()
|
|
|
|
--
|
|
2.23.0
|
|
|