kumquat-buildroot/package/ushare/0001-Don-t-build-po-files-if-NLS-is-disabled.patch
Fabrice Fontaine e63c8ceeea package/ushare: fix NLS build
Commit c4e1a07510 forgot to add
--enable-nls to patch resulting in the following build failure:

Unknown option "--enable-nls".

Fixes:
 - http://autobuild.buildroot.org/results/6ab2555b419355f01310f230fe612f2a3699bbfd

Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
2021-08-28 15:49:10 +02:00

57 lines
1.2 KiB
Diff

From c9f5783bb2df4a19c6281daeda30e8ab905d2ca3 Mon Sep 17 00:00:00 2001
From: Fabrice Fontaine <fontaine.fabrice@gmail.com>
Date: Sun, 22 Aug 2021 10:44:48 +0200
Subject: [PATCH] Don't build po files if NLS is disabled
Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
[Upstream status: https://github.com/ddugovic/uShare/pull/12]
---
Makefile | 7 +++++--
configure | 3 +++
2 files changed, 8 insertions(+), 2 deletions(-)
diff --git a/Makefile b/Makefile
index ebd8f91..6686cfd 100644
--- a/Makefile
+++ b/Makefile
@@ -14,10 +14,13 @@ EXTRADIST = AUTHORS \
THANKS \
TODO \
-SUBDIRS = po \
- scripts \
+SUBDIRS = scripts \
src \
+ifeq ($(NLS),yes)
+SUBDIRS += po
+endif
+
all:
for subdir in $(SUBDIRS); do \
$(MAKE) -C $$subdir $@; \
diff --git a/configure b/configure
index 4a3efe0..f48806a 100755
--- a/configure
+++ b/configure
@@ -414,6 +414,8 @@ for opt do
;;
--with-libdlna-dir=*) libdlnadir="$optval";
;;
+ --enable-nls) nls="yes"
+ ;;
--disable-nls) nls="no"
;;
--enable-dlna) dlna="yes"
@@ -723,6 +725,7 @@ append_config "LDFLAGS=$LDFLAGS"
append_config "INSTALL=$INSTALL"
append_config "DEBUG=$debug"
+append_config "NLS=$nls"
echolog "Creating $CONFIG_H ..."
--
2.32.0