5ff01eb31f
Signed-off-by: Adam Duskett <Aduskett@gmail.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
34 lines
869 B
Diff
34 lines
869 B
Diff
From 74007603df0921450f14e8626df36140426cc300 Mon Sep 17 00:00:00 2001
|
|
From: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
|
|
Date: Sat, 18 Aug 2018 10:54:56 +0200
|
|
Subject: [PATCH] Add an option to disable uuid module
|
|
|
|
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
|
|
---
|
|
configure.ac | 9 +++++++++
|
|
1 file changed, 9 insertions(+)
|
|
|
|
diff --git a/configure.ac b/configure.ac
|
|
index d07e371c57..55ab6c3c26 100644
|
|
--- a/configure.ac
|
|
+++ b/configure.ac
|
|
@@ -3330,6 +3330,15 @@ if test "$CURSES" = "no"; then
|
|
DISABLED_EXTENSIONS="${DISABLED_EXTENSIONS} _curses _curses_panel"
|
|
fi
|
|
|
|
+AC_SUBST(UUID)
|
|
+AC_ARG_ENABLE(uuid,
|
|
+ AS_HELP_STRING([--disable-uuid], [disable uuid]),
|
|
+ [ UUID="${enableval}" ], [ UUID=yes ])
|
|
+
|
|
+if test "$UUID" = "no"; then
|
|
+ DISABLED_EXTENSIONS="${DISABLED_EXTENSIONS} _uuid"
|
|
+fi
|
|
+
|
|
AC_SUBST(PYDOC)
|
|
|
|
AC_ARG_ENABLE(pydoc,
|
|
--
|
|
2.20.1
|
|
|