30849a53d4
sysrepo is a YANG-based configuration and operational state data store for Unix/Linux applications. It is a dependency of Netopeer, a NETCONF server. Both patches have been merged upstream. Signed-off-by: Heiko Thiery <heiko.thiery@kontron.com> [Arnout: fix sysvinit scripts to properly daemonize and to read /etc/default] Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
41 lines
1.3 KiB
Diff
41 lines
1.3 KiB
Diff
From 906927b4ee2dd0d5bd669d193fc851d14919fbd1 Mon Sep 17 00:00:00 2001
|
|
From: Michael Walle <michael@walle.cc>
|
|
Date: Thu, 10 Oct 2019 14:38:57 +0200
|
|
Subject: [PATCH] CMakeLists.txt: make systemd unit dir configurable
|
|
|
|
Patch comes from upstream pull-request:
|
|
https://github.com/sysrepo/sysrepo/pull/1638
|
|
|
|
Signed-off-by: Heiko Thiery <heiko.thiery@gmail.com>
|
|
---
|
|
CMakeLists.txt | 6 +++++-
|
|
1 file changed, 5 insertions(+), 1 deletion(-)
|
|
|
|
diff --git a/CMakeLists.txt b/CMakeLists.txt
|
|
index 14b7cd36..14c84675 100644
|
|
--- a/CMakeLists.txt
|
|
+++ b/CMakeLists.txt
|
|
@@ -217,6 +217,9 @@ else()
|
|
message(FATAL_ERROR "Unknown file format \"${FILE_FORMAT_EXT}\", must be json, xml, or lyb.")
|
|
endif()
|
|
|
|
+set(SYSTEMD_UNIT_DIR "lib/systemd/system/" CACHE STRING
|
|
+ "Path to the systemd service directory.")
|
|
+
|
|
# timeouts
|
|
set(REQUEST_TIMEOUT 15 CACHE STRING
|
|
"Timeout (in seconds) for Sysrepo API requests. Set to 0 for no timeout.")
|
|
@@ -357,7 +360,8 @@ if(WITH_SYSTEMD)
|
|
${PROJECT_SOURCE_DIR}/deploy/systemd/sysrepod.service
|
|
${PROJECT_SOURCE_DIR}/deploy/systemd/sysrepo-plugind.service
|
|
)
|
|
- install(DIRECTORY ${PROJECT_SOURCE_DIR}/deploy/systemd/ DESTINATION "lib/systemd/system"
|
|
+ install(DIRECTORY ${PROJECT_SOURCE_DIR}/deploy/systemd/
|
|
+ DESTINATION "${SYSTEMD_UNIT_DIR}"
|
|
FILES_MATCHING PATTERN "*.service")
|
|
endif()
|
|
|
|
--
|
|
2.20.1
|
|
|