2588aa8527
Switched to bz2 tarball, upstream does not provide a gz tarball anymore. Rebased 0001-slsh-libs.patch according to https://gitweb.gentoo.org/repo/gentoo.git/tree/sys-libs/slang/files/slang-2.3.1-slsh-libs.patch Removed patches applied upstream: 0002-Enable-a-statically-linked-version-of-slsh.patch 0003-Disable-module-support-in-the-statically-linked-version-of-slsh.patch 0005-make-install-static-do-install-pkgconfig-as-install-.patch Removed 0004-Rename-posix_close-function-to-posix_close_slfile.patch after upstream committed a different solution, Alpine Linux did the same when bumping to 2.3.1: https://git.alpinelinux.org/cgit/aports/commit/main/slang?id=d4d252e4dea77c868259b0ef1f3d9cfbe6dc2152 Added sha256 hash and license file hash. Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de> [Arnout: Added sha256 hash and license file hash.] Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
20 lines
1.0 KiB
Diff
20 lines
1.0 KiB
Diff
Link against sources instead of installation paths that aren't DESTDIRed.
|
|
Patch taken from gentoo portage, upstream status unknown, author
|
|
probably Diego Pettenò.
|
|
|
|
Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
|
|
[Bernd: rebased against 2.3.1a]
|
|
Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
|
|
|
|
--- a/slsh/Makefile.in
|
|
+++ b/slsh/Makefile.in
|
|
@@ -92,7 +92,7 @@
|
|
$(OBJDIR)/slsh_exe: $(OBJDIR)/slsh.o $(OBJDIR)/readline.o
|
|
$(CC) $(CFLAGS) $(OBJDIR)/slsh.o $(OBJDIR)/readline.o -o $(OBJDIR)/slsh_exe $(LDFLAGS) $(DLINK_FLAGS) $(SRC_LIBS)
|
|
$(OBJDIR)/slsh: $(OBJDIR)/slsh.o $(OBJDIR)/readline.o
|
|
- $(CC) $(CFLAGS) $(OBJDIR)/slsh.o $(OBJDIR)/readline.o -o $(OBJDIR)/slsh $(LDFLAGS) $(DLINK_FLAGS) $(INST_LIBS)
|
|
+ $(CC) $(CFLAGS) $(OBJDIR)/slsh.o $(OBJDIR)/readline.o -o $(OBJDIR)/slsh $(LDFLAGS) $(DLINK_FLAGS) $(SRC_LIBS)
|
|
$(OBJDIR)/slsh.o: $(OBJDIR_TSTAMP) slsh.c slsh.h config.h Makefile
|
|
cd $(OBJDIR) && $(CC) $(SLANG_SRCINC) $(CFLAGS) -c $(DEFS) $(SRCDIR)/slsh.c
|
|
$(OBJDIR)/readline.o: $(OBJDIR_TSTAMP) readline.c slsh.h config.h Makefile
|