5108554dfe
Since qemu started using ninja, they have the following fragment in the Makefile: MAKE.n = $(findstring n,$(firstword $(MAKEFLAGS))) NINJAFLAGS = ... $(if $(MAKE.n), -n) ... Buildroot's generated makefile in the O= directory invokes make in the base buildroot with --no-print-directory. However, make's placement of the --no-print-directory in MAKEFLAGS varies between the versions of the host make; make 4.3 places that at the end while make 3.82 places it at the beginning. As a result, if building on a system with an older host make, qemu's makefile invokes `ninja -n` which does not generate any outputs. To reproduce, on a CentOS 7 machine or docker image: mkdir /tmp/br-build && cd /tmp/br-build make -C ~/buildroot pc_x86_64_bios_defconfig O=`pwd` make menuconfig # Switch to glibc, enable "QEMU" and "QEMU tools" make all # Build succeeds find target -name qemu-img # No binary has been built Pick up the fix commited in Qemu upstream. Signed-off-by: Alexey Neyman <stilor@att.net> Signed-off-by: Yann E. MORIN <yann.morin.1998@free.fr>
42 lines
1.6 KiB
Diff
42 lines
1.6 KiB
Diff
From 14833e24dea49303ebc2464813601054b6cdfcac Mon Sep 17 00:00:00 2001
|
|
From: Alexey Neyman <stilor@att.net>
|
|
Date: Wed, 21 Jul 2021 19:08:46 -0700
|
|
Subject: [PATCH] Makefile: ignore long options
|
|
|
|
When searching for options like -n in MAKEFLAGS, current code may result
|
|
in a false positive match when make is invoked with long options like
|
|
--no-print-directory. This has been observed with certain versions of
|
|
host make (e.g. 3.82) while building the Qemu package in buildroot.
|
|
|
|
Filter out such long options before searching for one-character options.
|
|
|
|
Signed-off-by: Alexey Neyman <stilor@att.net>
|
|
Message-Id: <20210722020846.3678817-1-stilor@att.net>
|
|
Signed-off-by: Paolo Bonzini <pbonzini@redhat.com>
|
|
---
|
|
Makefile | 8 +++++---
|
|
1 file changed, 5 insertions(+), 3 deletions(-)
|
|
|
|
diff --git a/Makefile b/Makefile
|
|
index 6c36330eef..401c623a65 100644
|
|
--- a/Makefile
|
|
+++ b/Makefile
|
|
@@ -129,9 +129,11 @@ endif
|
|
# 4. Rules to bridge to other makefiles
|
|
|
|
ifneq ($(NINJA),)
|
|
-MAKE.n = $(findstring n,$(firstword $(MAKEFLAGS)))
|
|
-MAKE.k = $(findstring k,$(firstword $(MAKEFLAGS)))
|
|
-MAKE.q = $(findstring q,$(firstword $(MAKEFLAGS)))
|
|
+# Filter out long options to avoid flags like --no-print-directory which
|
|
+# may result in false positive match for MAKE.n
|
|
+MAKE.n = $(findstring n,$(firstword $(filter-out --%,$(MAKEFLAGS))))
|
|
+MAKE.k = $(findstring k,$(firstword $(filter-out --%,$(MAKEFLAGS))))
|
|
+MAKE.q = $(findstring q,$(firstword $(filter-out --%,$(MAKEFLAGS))))
|
|
MAKE.nq = $(if $(word 2, $(MAKE.n) $(MAKE.q)),nq)
|
|
NINJAFLAGS = $(if $V,-v) $(if $(MAKE.n), -n) $(if $(MAKE.k), -k0) \
|
|
$(filter-out -j, $(lastword -j1 $(filter -l% -j%, $(MAKEFLAGS)))) \
|
|
--
|
|
2.27.0
|
|
|