kumquat-buildroot/package/pppd/0003-Fixes-issue-429-stray-include-of-an-openssl-header-w.patch
Bernd Kuhls 0c15169f5a package/pppd: bump version to 2.5.0
Removed all patches, they are now included in this release.
Added other patches fixing errors.

Removed option BR2_PACKAGE_PPPD_RADIUS, upstream build system, now auto-
conf-based, does not support disabling the radius plugin.

Removed BR2_PACKAGE_PPPD_OVERWRITE_RESOLV_CONF, upstream now defaults to
/etc, quoting README:
"Note that if you have built and installed previous versions of this
package and you want to continue having configuration and TDB files in
/etc/ppp, you will need to use the --sysconfdir option to ./configure."

Switched build system to autoconf, added optional systemd support.

Added configure option to enable multilink support which now defaults to
false but was enabled before:
https://github.com/ppp-project/ppp/blob/2.4.9/pppd/Makefile.linux#L57

Signed-off-by: Bernd Kuhls <bernd@kuhls.net>
Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
2023-09-29 22:50:22 +02:00

32 lines
933 B
Diff

From cf7ac82a610bbfee57512cba345f7d49c02563a2 Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?Eivind=20N=C3=A6ss?= <eivnaes@yahoo.com>
Date: Wed, 14 Jun 2023 23:19:46 +0000
Subject: [PATCH] Fixes issue #429, stray include of an openssl header was
removed
MIME-Version: 1.0
Content-Type: text/plain; charset=UTF-8
Content-Transfer-Encoding: 8bit
Signed-off-by: Eivind Næss <eivnaes@yahoo.com>
Upstream: https://github.com/ppp-project/ppp/pull/431
Signed-off-by: Bernd Kuhls <bernd@kuhls.net>
---
pppd/crypto_ms.c | 2 --
1 file changed, 2 deletions(-)
diff --git a/pppd/crypto_ms.c b/pppd/crypto_ms.c
index a9ddd5fda..ccf8129d4 100644
--- a/pppd/crypto_ms.c
+++ b/pppd/crypto_ms.c
@@ -122,8 +122,6 @@ MakeKey(const unsigned char *key, unsigned char *des_key)
DES_set_odd_parity((DES_cblock *)des_key);
}
-#include <openssl/evp.h>
-
int
DesEncrypt(const unsigned char *clear, const unsigned char *key, unsigned char *cipher)
{