kumquat-buildroot/package/nfs-utils/0001-nfsrahead-fix-linking-while-static-linking.patch
Giulio Benetti 700fc2d7bd package/nfs-utils: handle pkg-config in the Autotools standard way for nfsrahead
While using the correct PKG_CHECK_MODULES() approach for libmount we
end up having host-nfs-utils needing libmount. But libmount is only
needed by nfsrahead that we don't need in host-nfs-utils. But we need
host-nfs-utils itself(rpcgen tool specifically) to build nfs-utils. To
solve this recursive situation:

1) Update the first patch with the upstreamed one that handles
   libmount using PKG_CHECK_MODULES().

2) Add another patch to allow to disable nfsrahead during building for
   host since this tool is not needed and requires libmount. This way
   the first patch approach can be correctly used.

3) Add --disable-nfsrahead to HOST_NFS_UTILS_CONF_OPTS

4) Remove en/disable-uuid since now it's required by default:
   http://git.linux-nfs.org/?p=steved/nfs-utils.git;a=commitdiff;h=c5528f40f9db5061e06dcf1f9b7fce5185b376c6

Both patches have been committed:
https://git.linux-nfs.org/?p=steved/nfs-utils.git;a=commit;h=627c95b2b853161b359095e7fdf05d3b07d51379
https://git.linux-nfs.org/?p=steved/nfs-utils.git;a=commit;h=844d3ad5376603bc9c205a6084d38a2d25146179

Signed-off-by: Giulio Benetti <giulio.benetti@benettiengineering.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
2023-02-07 18:38:53 +01:00

50 lines
1.5 KiB
Diff

From d9abb221cea81dee5956bd987c6efa680c03571a Mon Sep 17 00:00:00 2001
From: Giulio Benetti <giulio.benetti@benettiengineering.com>
Date: Wed, 10 Aug 2022 23:38:17 +0200
Subject: [PATCH] nfsrahead: fix linking while static linking
-lmount must preceed -lblkid and to obtain this let's add in configure.ac:
PKG_CHECK_MODULES([LIBMOUNT], [mount])
and in tools/nfsrahead/Makefile.am let's substitute explicit `-lmount`
with:
$(LIBMOUNT_LIBS)
This way all the required libraries will be present and in the right order
when static linking.
Signed-off-by: Giulio Benetti <giulio.benetti@benettiengineering.com>
[Upstream: https://git.linux-nfs.org/?p=steved/nfs-utils.git;a=commit;h=627c95b2b853161b359095e7fdf05d3b07d51379]
---
configure.ac | 3 +++
tools/nfsrahead/Makefile.am | 2 +-
2 files changed, 4 insertions(+), 1 deletion(-)
diff --git a/configure.ac b/configure.ac
index f1c46c5c..ff85200b 100644
--- a/configure.ac
+++ b/configure.ac
@@ -273,6 +273,9 @@ AC_LIBCAP
dnl Check for -lxml2
AC_LIBXML2
+dnl Check for -lmount
+PKG_CHECK_MODULES([LIBMOUNT], [mount])
+
# Check whether user wants TCP wrappers support
AC_TCP_WRAPPERS
diff --git a/tools/nfsrahead/Makefile.am b/tools/nfsrahead/Makefile.am
index 845ea0d5..7e08233a 100644
--- a/tools/nfsrahead/Makefile.am
+++ b/tools/nfsrahead/Makefile.am
@@ -1,6 +1,6 @@
libexec_PROGRAMS = nfsrahead
nfsrahead_SOURCES = main.c
-nfsrahead_LDFLAGS= -lmount
+nfsrahead_LDFLAGS= $(LIBMOUNT_LIBS)
nfsrahead_LDADD = ../../support/nfs/libnfsconf.la
man5_MANS = nfsrahead.man
--
2.34.1