339df19f7a
- Bump version to 1.5.9 - Remove patches already included in this version - Use make parameters instead of environment variables - Add an upstream patch to fix building statically - Adapt old patches to the new version - Add a hash file Fixes: http://autobuild.buildroot.net/results/ced/ced596bd1c73286f7044f5a8e11b6588fc973f11/ Signed-off-by: Vicente Olivert Riera <Vincent.Riera@imgtec.com> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
20 lines
490 B
Diff
20 lines
490 B
Diff
Makefile: Don't call "ln" directly
|
|
|
|
Signed-off-by: Vicente Olivert Riera <vincent.riera@imgtec.com>
|
|
|
|
--- keyutils-1.5.9/Makefile.orig 2014-09-22 16:05:14.117007430 +0100
|
|
+++ keyutils-1.5.9/Makefile 2014-09-22 16:06:26.053219336 +0100
|
|
@@ -123,10 +123,10 @@ endif
|
|
ifeq ($(NO_SOLIB),0)
|
|
all: $(DEVELLIB)
|
|
$(DEVELLIB): $(SONAME)
|
|
- ln -sf $< $@
|
|
+ $(LNS) $< $@
|
|
|
|
$(SONAME): $(LIBNAME)
|
|
- ln -sf $< $@
|
|
+ $(LNS) $< $@
|
|
|
|
LIBVERS := -shared -Wl,-soname,$(SONAME) -Wl,--version-script,version.lds
|
|
|