ac8b5ffef1
Bumping to brand new stable version 1.8 Upstreamed patches are dropped, sane patch is rebased. Adding libpcap, pulseaudio and samba4 as soft dependencies. sfnt2fon moved to its own subfolder and needs to be built in host-wine. Signed-off-by: André Hentschel <nerv@dawncrow.de> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
22 lines
893 B
Diff
22 lines
893 B
Diff
Add support for SANE_CONFIG variable
|
|
|
|
Instead of using directly the sane-config command, allow to pass a
|
|
SANE_CONFIG environment variable to override where to find the
|
|
sane-config tool.
|
|
|
|
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
|
|
|
|
Index: b/configure.ac
|
|
===================================================================
|
|
--- a/configure.ac
|
|
+++ b/configure.ac
|
|
@@ -1291,7 +1291,7 @@
|
|
dnl **** Check for SANE ****
|
|
if test "x$with_sane" != "xno"
|
|
then
|
|
- WINE_PACKAGE_FLAGS(SANE,[libsane],,[`sane-config --cflags 2>/dev/null`],[`sane-config --ldflags 2>/dev/null`],
|
|
+ WINE_PACKAGE_FLAGS(SANE,[libsane],,[`${SANE_CONFIG:-sane-config} --cflags 2>/dev/null`],[`${SANE_CONFIG:-sane-config} --ldflags 2>/dev/null`],
|
|
[AC_CHECK_HEADER(sane/sane.h,
|
|
[WINE_CHECK_SONAME(sane,sane_init,,[SANE_CFLAGS=""],[$SANE_LIBS])],
|
|
[SANE_CFLAGS=""])])
|