f1c092da8b
Some of the python2 patches were left behind when doing the python3 package. This was because the python build system can now autodetect what packages can be built in the system. However, some of these patches are actually useful to reduce drastically the size of the interpreter. This patch ports the relevant patches to the python3 package, and adds a new patch to remove the idle3 IDE as well from the interpreter. Fixes #5696 Signed-off-by: Maxime Ripard <maxime.ripard@free-electrons.com> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
22 lines
656 B
Diff
22 lines
656 B
Diff
Disable buggy_getaddrinfo configure test when cross-compiling with IPv6 support
|
|
|
|
Signed-off-by: Vanya Sergeev <vsergeev at gmail.com>
|
|
|
|
---
|
|
configure.ac | 2 +-
|
|
1 file changed, 1 insertion(+), 1 deletion(-)
|
|
|
|
Index: Python-3.3.0/configure.ac
|
|
===================================================================
|
|
--- Python-3.3.0.orig/configure.ac
|
|
+++ Python-3.3.0/configure.ac
|
|
@@ -3204,7 +3204,7 @@
|
|
|
|
AC_MSG_RESULT($ac_cv_buggy_getaddrinfo)
|
|
|
|
-if test $have_getaddrinfo = no || test "$ac_cv_buggy_getaddrinfo" = yes
|
|
+if test $have_getaddrinfo = no || test "$cross_compiling" != "yes" -a "$ac_cv_buggy_getaddrinfo" = yes
|
|
then
|
|
if test $ipv6 = yes
|
|
then
|