kumquat-buildroot/package/python3/0024-Add-an-option-to-disable-the-readline-module.patch
James Hilliard 738500c296 package/python3: bump to version 3.11.0
Add new host-pkgconf host python3 dependency.

Set new --with-build-python conf options for target python build.

Drop Fix cross compiling the uuid module patch which is no longer
required as pkgconfig is now used for include directory detection.

Refresh patches.

License hash changed due to year update:
ba00f0d93a

Signed-off-by: James Hilliard <james.hilliard1@gmail.com>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
2022-11-03 23:10:05 +01:00

31 lines
895 B
Diff

From 9082468ca620db77b670ccf568a96bbabb865f80 Mon Sep 17 00:00:00 2001
From: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
Date: Tue, 7 Mar 2017 23:29:05 +0100
Subject: [PATCH] Add an option to disable the readline module
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
---
configure.ac | 6 ++++++
1 file changed, 6 insertions(+)
diff --git a/configure.ac b/configure.ac
index 42fe6c8f5a..19875d7d30 100644
--- a/configure.ac
+++ b/configure.ac
@@ -4225,6 +4225,12 @@ AC_ARG_ENABLE(openssl,
DISABLED_EXTENSIONS="${DISABLED_EXTENSIONS} ssl _ssl _hashlib"
fi])
+AC_ARG_ENABLE(readline,
+ AS_HELP_STRING([--disable-readline], [disable readline]),
+ [ if test "$enableval" = "no"; then
+ DISABLED_EXTENSIONS="${DISABLED_EXTENSIONS} readline"
+ fi])
+
AC_SUBST(TK)
AC_ARG_ENABLE(tk,
AS_HELP_STRING([--disable-tk], [disable tk]),
--
2.34.1