f95c7e6fb9
[Thomas: - Rename patch to the proper naming convention, and add a description to it. - Add mandatory dependency to OpenSSL. - Make the dependency on libwebsock optional. - Remove select of host-gengetopt, since this package no longer has a menuconfig option. - Add missing toolchain option dependencies inherited from selected packages. - Add proper Config.in help text. - Fix the .mk comment header to the proper format. - Use the github function and remove the unneeded SITE_METHOD variable. - Add support for optional Opus and Libogg support. - Remove hash file, since the package is fetched from github.] Signed-off-by: Gregory Dymarek <gregd72002@gmail.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
21 lines
893 B
Diff
21 lines
893 B
Diff
Do not force SSP usage
|
|
|
|
The toolchain may not support SSP, so do not enforce its usage, let
|
|
the package user pass the appropriate CFLAGS to enable SSP if needed.
|
|
|
|
Signed-off-by: Gregory Dymarek <gregd72002@gmail.com>
|
|
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
|
|
|
|
diff -rupN janus-gateway-master.orig/Makefile.am janus-gateway-master/Makefile.am
|
|
--- janus-gateway-master.orig/Makefile.am 2014-11-27 14:36:31.000000000 +0000
|
|
+++ janus-gateway-master/Makefile.am 2014-12-01 16:39:50.551935028 +0000
|
|
@@ -14,7 +14,7 @@ AM_CFLAGS += -Wredundant-decls # sophia
|
|
# some fairly big refactoring though, which can wait.
|
|
# AM_CFLAGS += -Wshadow -Wstrict-aliasing=2
|
|
|
|
-AM_CFLAGS += -fstack-protector-all -g -ggdb -fPIC -rdynamic
|
|
+AM_CFLAGS += -g -ggdb -fPIC -rdynamic
|
|
|
|
# FIXME: make docs work with distcheck
|
|
DISTCHECK_CONFIGURE_FLAGS = --disable-docs --enable-post-processing
|