8773e0aba0
Fix the following musl build failure raised since bump to version 1.7 in commit3ef4d24192
and https://git.gnupg.org/cgi-bin/gitweb.cgi?p=npth.git;a=commit;h=575573b5b63e147b1906240f192dbe37a26ca4b9: npth.c:392:21: error: unknown type name 'npth_rwlock_t'; did you mean 'npth_cond_t'? 392 | npth_rwlock_rdlock (npth_rwlock_t *rwlock) | ^~~~~~~~~~~~~ | npth_cond_t Fixes:3ef4d24192
- http://autobuild.buildroot.org/results/d986ba27b734679fd70b4e0f23278ebd38e13c5d Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com> (cherry picked from commit8c456a5646
) Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
38 lines
1005 B
Diff
38 lines
1005 B
Diff
From 417abd56fd7bf45cd4948414050615cb1ad59134 Mon Sep 17 00:00:00 2001
|
|
From: NIIBE Yutaka <gniibe@fsij.org>
|
|
Date: Fri, 1 Mar 2024 13:53:52 +0900
|
|
Subject: [PATCH] Fix INSERT_EXPOSE_RWLOCK_API for musl C library.
|
|
|
|
* configure.ac: Add a case for musl system.
|
|
|
|
--
|
|
|
|
GnuPG-bug-id: 5664
|
|
Signed-off-by: NIIBE Yutaka <gniibe@fsij.org>
|
|
|
|
Upstream: https://git.gnupg.org/cgi-bin/gitweb.cgi?p=npth.git;a=commit;h=417abd56fd7bf45cd4948414050615cb1ad59134
|
|
Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
|
|
---
|
|
configure.ac | 5 ++++-
|
|
1 file changed, 4 insertions(+), 1 deletion(-)
|
|
|
|
diff --git a/configure.ac b/configure.ac
|
|
index c1091b1..576a26e 100644
|
|
--- a/configure.ac
|
|
+++ b/configure.ac
|
|
@@ -381,7 +381,10 @@ fi
|
|
AC_SUBST(INSERT_NO_RWLOCK)
|
|
|
|
case "${host}" in
|
|
- *-*-linux*|*-*-gnu*)
|
|
+ *-*-linux-musl*)
|
|
+ INSERT_EXPOSE_RWLOCK_API="1"
|
|
+ ;;
|
|
+ *-*-linux-gnu*|*-*-gnu*)
|
|
INSERT_EXPOSE_RWLOCK_API="defined(__USE_UNIX98) || defined(__USE_XOPEN2K)"
|
|
;;
|
|
*)
|
|
--
|
|
2.30.2
|
|
|