7687a396e8
GObject introspection is a middleware layer between C libraries (using GObject) and language bindings. The C library can be scanned at compile time and generate a metadata file, in addition to the actual native C library. Then at runtime, language bindings can read this metadata and automatically provide bindings to call into the C library. There's an XML format called GIR used by GObject-Introspection. The purpose of it is to provide a standard structure to access the complete available API that a library or other unit of code exports. It's language-agnostic using namespaces to separate core, language, or library-specific functionality. Cross-compiling gobject-introspection is not an easy task. The main issue is that in the process of creating the XML files, gobject-introspection must first run and scan the binary, which, if the binary is cross-compiled, would not typically be possible from the host system. Because of this limitation, we use several wrappers to call instead first out qemu, which runs the native scanner to create the binaries. There are seven total patches and four different wrapper files needed to successfully cross-compile and run this package, many of them are from open-embedded, but one of them is of my own doing. 1) Revert a previous, incomplete attempt at adding cross-compiling support. 2) Add support for cross-compiling with meson. 3) Disable tests. 4) Add an option to use a binary wrapper; this patch will force giscanner to use a wrapper executable to run binaries it's producing, instead of attempting to run them from the host. 5) Add an option to use an LDD wrapper, again, useful for cross-compiled environments. 6) Add a --lib-dirs-envar option to pass to giscanner. (See patch for details.) 7) Add rpath-links to ccompiler: when passing the PACKAGE_GIR_EXTRA_LIBS_PATH to the ccompiler.py script, ccompiler.py needs to add -Wl,-rpath-link to the environment for the package to correctly link against the passed on paths. 8) Ignore error return codes from ldd-wrapper because prelink-rtld returns 127 when it can't find a library, which breaks subprocess.check_output(). Signed-off-by: Adam Duskett <Aduskett@gmail.com> Tested-by: Yegor Yefremov <yegorslists@googlemail.com> Tested-by: Giulio Benetti <giulio.benetti@benettiengineering.com> [yann.morin.1998@free.fr: - host-prelink-cross has no Kconfig entry - reorder dependencies for arch deps first ] Signed-off-by: Yann E. MORIN <yann.morin.1998@free.fr>
30 lines
915 B
Diff
30 lines
915 B
Diff
From 473b4288d8f4e891d0d21f7b60ef8053c5cd7af9 Mon Sep 17 00:00:00 2001
|
|
From: Adam Duskett <aduskett@gmail.com>
|
|
Date: Mon, 3 Feb 2020 10:07:15 -0800
|
|
Subject: [PATCH] disable tests
|
|
|
|
If introspection data on the host is not built, meson throws the error:
|
|
"Unknown variable "typelibs". Because tests are not required, removing
|
|
the subdir tests alltogether fixes this issue.
|
|
|
|
Signed-off-by: Adam Duskett <aduskett@gmail.com>
|
|
---
|
|
meson.build | 1 -
|
|
1 file changed, 1 deletion(-)
|
|
|
|
diff --git a/meson.build b/meson.build
|
|
index a5e825f..981e936 100644
|
|
--- a/meson.build
|
|
+++ b/meson.build
|
|
@@ -171,7 +171,6 @@ subdir('giscanner')
|
|
subdir('gir')
|
|
subdir('examples')
|
|
subdir('docs')
|
|
-subdir('tests')
|
|
|
|
install_data('Makefile.introspection', install_dir: join_paths(get_option('datadir'), 'gobject-introspection-1.0'))
|
|
install_data('m4/introspection.m4', install_dir: join_paths(get_option('datadir'), 'aclocal'))
|
|
--
|
|
2.24.1
|
|
|