12c430f880
Current python-automat version 20.2.0 no longer work with Python 3.11
updated in commit 738500c296
.
Running package runtime test with command:
support/testing/run-tests \
-d dl \
-o output_folder \
tests.package.test_python_automat.TestPythonPy3Automat
Fails with output:
Traceback (most recent call last):
File "/root/sample_python_automat.py", line 27, in <module>
led.turn_on()
^^^^^^^^^^^
File "/usr/lib/python3.11/site-packages/automat/_methodical.py", line 232, in __get__
File "/usr/lib/python3.11/site-packages/automat/_introspection.py", line 43, in decorator
File "/usr/lib/python3.11/site-packages/automat/_introspection.py", line 35, in copyfunction
File "/usr/lib/python3.11/site-packages/automat/_introspection.py", line 23, in copycode
TypeError: code() argument 13 must be str, not int
This commit fixes this issue by updating the package to the latest
version.
Signed-off-by: Julien Olivain <ju.o@free.fr>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
29 lines
708 B
Diff
29 lines
708 B
Diff
From d04d51d62a23370869ad466fa95b7d4ec2e0fa6e Mon Sep 17 00:00:00 2001
|
|
From: Julien Olivain <ju.o@free.fr>
|
|
Date: Mon, 14 Nov 2022 22:30:33 +0100
|
|
Subject: [PATCH] Remove uneeded dependency to "wheel"
|
|
|
|
Attempting to build Automat in Buildroot fails while trying
|
|
to check for this undeeded dependency.
|
|
|
|
Signed-off-by: Julien Olivain <ju.o@free.fr>
|
|
---
|
|
setup.py | 1 -
|
|
1 file changed, 1 deletion(-)
|
|
|
|
diff --git a/setup.py b/setup.py
|
|
index c2f9816..afa8012 100644
|
|
--- a/setup.py
|
|
+++ b/setup.py
|
|
@@ -15,7 +15,6 @@ setup(
|
|
packages=find_packages(exclude=[]),
|
|
package_dir={'automat': 'automat'},
|
|
setup_requires=[
|
|
- 'wheel',
|
|
'setuptools-scm',
|
|
],
|
|
install_requires=[
|
|
--
|
|
2.38.1
|
|
|