6520762932
Now that the cpython project has a nice Github repository, with tags, it's much nicer to handle the stack of Python patches with Git. The python3 package patches had already been converted, but not the python package patches. Therefore, this commit does the move. There is no functional change, only reformatting of the patches. Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Reviewed-by: Yegor Yefremov <yegorslists@googlemail.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
31 lines
925 B
Diff
31 lines
925 B
Diff
From a131e2ff219872d97eef6585117bd2f8ff9e310d Mon Sep 17 00:00:00 2001
|
|
From: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
|
|
Date: Tue, 7 Mar 2017 22:24:48 +0100
|
|
Subject: [PATCH] Abort on failed module build
|
|
|
|
When building a Python module fails, the setup.py script currently
|
|
doesn't exit with an error, and simply continues. This is not a really
|
|
nice behavior, so this patch changes setup.py to abort with an error,
|
|
so that the build issue is clearly noticeable.
|
|
|
|
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
|
|
---
|
|
setup.py | 1 +
|
|
1 file changed, 1 insertion(+)
|
|
|
|
diff --git a/setup.py b/setup.py
|
|
index 0b9ea57..9a5c2b8 100644
|
|
--- a/setup.py
|
|
+++ b/setup.py
|
|
@@ -299,6 +299,7 @@ class PyBuildExt(build_ext):
|
|
print "Failed to build these modules:"
|
|
print_three_column(failed)
|
|
print
|
|
+ sys.exit(1)
|
|
|
|
def build_extension(self, ext):
|
|
|
|
--
|
|
2.7.4
|
|
|