b5d9900842
Fix several issues regarding the support for Flat Image Trees (FIT). - Add a patch to really allow turning FIT support on/off, which was not possible due to bugs in the code and in the tools Makefile. This patch has been sent upstream but not applied there, yet. - Use independent options to control FIT support on host and target packages. - Subordinate FIT signature support to the activation of FIT support, in the target package, not to mkimage installation. - Add a dependence on the dtc utilities because mkimage needs it when FIT is enabled; otherwise mkimage fails like this: $ mkimage -f firmware.its firmware.im sh: dtc: command not found - Add BR2_PACKAGE_UBOOT_TOOLS_MKIMAGE_FIT_SIGNATURE_SUPPORT to the Config.in.legacy file. Signed-off-by: Carlos Santos <casantos@datacom.ind.br> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
94 lines
2.9 KiB
Diff
94 lines
2.9 KiB
Diff
From ddcd6cd622889a2d74d0a16efae8e3b2d098f717 Mon Sep 17 00:00:00 2001
|
|
From: Carlos Santos <casantos@datacom.ind.br>
|
|
Date: Sun, 8 May 2016 11:11:39 -0300
|
|
Subject: [PATCH] Make FIT support really optional
|
|
|
|
Due to some mistakes in the source code, it was not possible to really
|
|
turn FIT support off. This commit fixes the problem by means of the
|
|
following changes:
|
|
|
|
- Enclose "bootm_host_load_image" and "bootm_host_load_images" between
|
|
checks for CONFIG_FIT_SIGNATURE, in common/bootm.c.
|
|
|
|
- Enclose the declaration of "bootm_host_load_images" between checks for
|
|
CONFIG_FIT_SIGNATURE, in common/bootm.h.
|
|
|
|
- Condition the compilation and linking of fit_common.o fit_image.o
|
|
image-host.o common/image-fit.o to CONFIG_FIT=y, in tools/Makefile.
|
|
|
|
Signed-off-by: Carlos Santos <casantos@datacom.ind.br>
|
|
---
|
|
common/bootm.c | 2 ++
|
|
include/bootm.h | 2 ++
|
|
tools/Makefile | 6 ++----
|
|
3 files changed, 6 insertions(+), 4 deletions(-)
|
|
|
|
diff --git a/common/bootm.c b/common/bootm.c
|
|
index c965326..ab477ba 100644
|
|
--- a/common/bootm.c
|
|
+++ b/common/bootm.c
|
|
@@ -891,6 +891,7 @@ void memmove_wd(void *to, void *from, size_t len, ulong chunksz)
|
|
memmove(to, from, len);
|
|
}
|
|
|
|
+#if defined(CONFIG_FIT_SIGNATURE)
|
|
static int bootm_host_load_image(const void *fit, int req_image_type)
|
|
{
|
|
const char *fit_uname_config = NULL;
|
|
@@ -955,5 +956,6 @@ int bootm_host_load_images(const void *fit, int cfg_noffset)
|
|
/* Return the first error we found */
|
|
return err;
|
|
}
|
|
+#endif
|
|
|
|
#endif /* ndef USE_HOSTCC */
|
|
diff --git a/include/bootm.h b/include/bootm.h
|
|
index 4981377..94d62a1 100644
|
|
--- a/include/bootm.h
|
|
+++ b/include/bootm.h
|
|
@@ -41,7 +41,9 @@ void lynxkdi_boot(image_header_t *hdr);
|
|
|
|
boot_os_fn *bootm_os_get_boot_func(int os);
|
|
|
|
+#if defined(CONFIG_FIT_SIGNATURE)
|
|
int bootm_host_load_images(const void *fit, int cfg_noffset);
|
|
+#endif
|
|
|
|
int boot_selected_os(int argc, char * const argv[], int state,
|
|
bootm_headers_t *images, boot_os_fn *boot_fn);
|
|
diff --git a/tools/Makefile b/tools/Makefile
|
|
index da50e1b..0a3d279 100644
|
|
--- a/tools/Makefile
|
|
+++ b/tools/Makefile
|
|
@@ -54,6 +54,7 @@ mkenvimage-objs := mkenvimage.o os_support.o lib/crc32.o
|
|
hostprogs-y += dumpimage mkimage
|
|
hostprogs-$(CONFIG_FIT_SIGNATURE) += fit_info fit_check_sign
|
|
|
|
+FIT_OBJS-$(CONFIG_FIT) := fit_common.o fit_image.o image-host.o common/image-fit.o
|
|
FIT_SIG_OBJS-$(CONFIG_FIT_SIGNATURE) := common/image-sig.o
|
|
# Flattened device tree objects
|
|
LIBFDT_OBJS := $(addprefix lib/libfdt/, \
|
|
@@ -68,18 +69,15 @@ ROCKCHIP_OBS = lib/rc4.o rkcommon.o rkimage.o rksd.o rkspi.o
|
|
# common objs for dumpimage and mkimage
|
|
dumpimage-mkimage-objs := aisimage.o \
|
|
atmelimage.o \
|
|
+ $(FIT_OBJS-y) \
|
|
$(FIT_SIG_OBJS-y) \
|
|
common/bootm.o \
|
|
lib/crc32.o \
|
|
default_image.o \
|
|
lib/fdtdec_common.o \
|
|
lib/fdtdec.o \
|
|
- fit_common.o \
|
|
- fit_image.o \
|
|
gpimage.o \
|
|
gpimage-common.o \
|
|
- common/image-fit.o \
|
|
- image-host.o \
|
|
common/image.o \
|
|
imagetool.o \
|
|
imximage.o \
|
|
--
|
|
2.7.4
|
|
|