02ea01ea22
We need to backport a few upstream still-pending PRs, to fix cross-compilation, out-of-tree installation, and to relax requirements on some tools. The python support PR is backported too, but because python support was not tested, it is forcibly disabled. Signed-off-by: James Hilliard <james.hilliard1@gmail.com> [yann.morin.1998@free.fr: - expand commit log with explanations - backport upstream 253 (python) too ] Signed-off-by: Yann E. MORIN <yann.morin.1998@free.fr>
34 lines
1.3 KiB
Diff
34 lines
1.3 KiB
Diff
From 586bb97459e72da30bd9991c228b6b8e9251c68b Mon Sep 17 00:00:00 2001
|
|
From: James Hilliard <james.hilliard1@gmail.com>
|
|
Date: Tue, 14 Sep 2021 01:49:49 -0600
|
|
Subject: [PATCH] Don't require gstreamer-check-1.0 unless tests are enabled.
|
|
|
|
Signed-off-by: James Hilliard <james.hilliard1@gmail.com>
|
|
[Upstream status:
|
|
https://github.com/RidgeRun/gstd-1.x/pull/248]
|
|
---
|
|
meson.build | 4 +++-
|
|
1 file changed, 3 insertions(+), 1 deletion(-)
|
|
|
|
diff --git a/meson.build b/meson.build
|
|
index 1d9ce9d..76990a0 100644
|
|
--- a/meson.build
|
|
+++ b/meson.build
|
|
@@ -22,10 +22,12 @@ gio_unix_dep = dependency('gio-unix-2.0', version : '>=2.44.1')
|
|
json_glib_dep = dependency('json-glib-1.0', version : '>=0.16.2')
|
|
libd_dep = dependency('libdaemon', version : '>=0.14')
|
|
jansson_dep = dependency('jansson', version : '>=2.7')
|
|
-gst_check_dep = dependency('gstreamer-check-1.0',version : '>=1.0.5')
|
|
thread_dep = dependency('threads')
|
|
libsoup_dep = dependency('libsoup-2.4', version : '>=2.4')
|
|
|
|
+gst_check_required = get_option('enable-tests').enabled()
|
|
+gst_check_dep = dependency('gstreamer-check-1.0', required : gst_check_required, version : '>=1.0.5')
|
|
+
|
|
systemd_required = get_option('enable-systemd').enabled()
|
|
systemd_dep = dependency('systemd', required : systemd_required, version : '>=232')
|
|
|
|
--
|
|
2.25.1
|
|
|