4146e12c1b
Reworked raspberry pi handling, it is not treated as separate platform anymore. Added dependencies to autoreconf cpluff. The autoreconf is normally called from CMake, but it's better if we do it under our control. Rebased patch - 0001-kodi-config.cmake-use-CMAKE_FIND_ROOT_PATH-to-fix-cr.patch Removed unneeded patch - 0002-CMake-Remove-dependency-on-gmp-and-libintl-from-Find.patch Removed backported patches - 0003-cmake-iconv-is-a-required-dependency.patch - 0004-Fix-ffmpeg-build-for-mips.patch - kodi-texturepacker/0002-fix_reallocarray.patch Added backported patches - 0003-Add-missing-cassert-includes.patch - 0004-Backport-Add-missing-cstddef-includes.patch Updated dependencies - bzip2 is not used anymore - flatbuffers (upstream PR 14209) - fmt (upstream PR 11039) - fstrcmp (upstream PR 14221) - yajl was replaced by RapidJSON (upstream PR 8008) - internal rar support was removed (upstream PR 11912) CMake option ENABLE_NONFREE was also removed - internal sftp support was removed (upstream PR 12005) - host-zip was removed (upstream PR 12643) - CMake option ENABLE_OPENSSL was removed (upstream PR 13650) - lirc support is now provided by lirc-tools (upstream PR 13761) - IMX support was removed (upstream PR 12990) - ENABLE_X11 was renamed to -DCORE_PLATFORM_NAME=x11 (upstream PR 12134) License hash changes because it was converted to markdown. Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de> Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
28 lines
1.1 KiB
Diff
28 lines
1.1 KiB
Diff
Fix stand-alone build
|
|
|
|
CMake Error at CMakeLists.txt:40 (add_executable):
|
|
Cannot find source file:
|
|
|
|
/home/bernd/buildroot/output/build/host-kodi-texturepacker-18.4-Leia/tools/depends/native/TexturePacker/xbmc/guilib/XBTF.cpp
|
|
|
|
Tried extensions .c .C .c++ .cc .cpp .cxx .cu .m .M .mm .h .hh .h++ .hm
|
|
.hpp .hxx .in .txx
|
|
|
|
CMake Error at CMakeLists.txt:40 (add_executable):
|
|
No SOURCES given to target: TexturePacker
|
|
|
|
Downloaded from
|
|
https://github.com/LibreELEC/LibreELEC.tv/blob/master/packages/mediacenter/kodi/patches/kodi-100.25-hack-fix-texture-packer-cmake-source-dir.patch
|
|
|
|
Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
|
|
|
|
diff -Naur a/tools/depends/native/TexturePacker/CMakeLists.txt b/tools/depends/native/TexturePacker/CMakeLists.txt
|
|
--- a/tools/depends/native/TexturePacker/CMakeLists.txt 2016-12-23 17:10:28.593185862 +0000
|
|
+++ b/tools/depends/native/TexturePacker/CMakeLists.txt 2016-12-23 17:10:39.469253011 +0000
|
|
@@ -1,3 +1,5 @@
|
|
+set(CMAKE_SOURCE_DIR ${CMAKE_SOURCE_DIR}/../../../..)
|
|
+
|
|
list(APPEND CMAKE_MODULE_PATH ${CMAKE_SOURCE_DIR}/cmake/modules)
|
|
|
|
if(APPLE)
|