kumquat-buildroot/package/vlc/0004-Drop-error-implicit-function-declaration-compile-fla.patch
Thomas Petazzoni 0fb1b80532 vlc: switch to proper Git formatted patches
VLC uses Git as its version control system, so it makes sense to use
Git formatted patches.

Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
2018-05-01 22:33:59 +02:00

33 lines
1.2 KiB
Diff

From d4806743a059ec6720b5c29e7345390978614fc9 Mon Sep 17 00:00:00 2001
From: Bernd Kuhls <bernd.kuhls@t-online.de>
Date: Tue, 1 May 2018 22:29:29 +0200
Subject: [PATCH] Drop error-implicit-function-declaration compile flag
Fix compile warning being treated as error:
codec/svg.c: In function 'DecodeBlock':
codec/svg.c:240:5: error: implicit declaration of function 'rsvg_handle_render_cairo' [-Werror=implicit-function-declaration]
cc1: some warnings being treated as errors
Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
---
configure.ac | 2 +-
1 file changed, 1 insertion(+), 1 deletion(-)
diff --git a/configure.ac b/configure.ac
index 9a37656ddd..b14ba46797 100644
--- a/configure.ac
+++ b/configure.ac
@@ -867,7 +867,7 @@ dnl
dnl Compiler warnings
dnl
-RDC_PROG_CC_WFLAGS([all extra sign-compare undef pointer-arith bad-function-cast write-strings missing-prototypes volatile-register-var error-implicit-function-declaration])
+RDC_PROG_CC_WFLAGS([all extra sign-compare undef pointer-arith bad-function-cast write-strings missing-prototypes volatile-register-var])
RDC_PROG_CC_FLAGS([-pipe])
AC_LANG_PUSH([C++])
RDC_PROG_CXX_WFLAGS([all extra sign-compare undef pointer-arith volatile-register-var])
--
2.14.3