6e6e8d37b5
Bump Python3 version to 3.6.2. Patches dropped: "Support PGEN_FOR_BUILD and FREEZE_IMPORTLIB_FOR_BUILD" Rationale: With commit 9d02f562961efd12d3c8317a10916db7f77330cc, code generation step of building CPython now became explicit (instead of always performed as a part of 'make' invocation) and more granular. We no longer need to use Parser/pgen at all and tricking the build system into using different Programs/_freeze_importlib can be done as a part of recipe. Additional info about the build change can be found at https://bugs.python.org/issue23404 Signed-off-by: Andrey Smirnov <andrew.smirnov@gmail.com> Tested-by: Bernd Kuhls <bernd.kuhls@t-online.de> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
38 lines
1.4 KiB
Diff
38 lines
1.4 KiB
Diff
From 660ea434ad8f921db74c0e3f93aa3ff5daac44f3 Mon Sep 17 00:00:00 2001
|
|
From: Samuel Cabrero <samuelcabrero@gmail.com>
|
|
Date: Wed, 23 Dec 2015 11:45:48 +0100
|
|
Subject: [PATCH] Override system locale and set to default when adding gcc
|
|
paths
|
|
|
|
Forces the use of the default locale in the function
|
|
add_gcc_paths, which is called when cross compiling to add the
|
|
include and library paths. This is necessary because otherwise
|
|
the gcc output is localized and the output parsing fails, which
|
|
results in no paths added and detect_modules not able to find
|
|
any system library (eg. libz, libssl, etc.)
|
|
|
|
[Thomas: patch taken from https://bugs.python.org/issue23767.]
|
|
|
|
Signed-off-by: Samuel Cabrero <samuelcabrero@gmail.com>
|
|
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
|
|
---
|
|
setup.py | 2 +-
|
|
1 file changed, 1 insertion(+), 1 deletion(-)
|
|
|
|
diff --git a/setup.py b/setup.py
|
|
index b3add2be76..29bfd174d2 100644
|
|
--- a/setup.py
|
|
+++ b/setup.py
|
|
@@ -457,7 +457,7 @@ class PyBuildExt(build_ext):
|
|
tmpfile = os.path.join(self.build_temp, 'gccpaths')
|
|
if not os.path.exists(self.build_temp):
|
|
os.makedirs(self.build_temp)
|
|
- ret = os.system('%s -E -v - </dev/null 2>%s 1>/dev/null' % (gcc, tmpfile))
|
|
+ ret = os.system('LC_ALL=C %s -E -v - </dev/null 2>%s 1>/dev/null' % (gcc, tmpfile))
|
|
is_gcc = False
|
|
in_incdirs = False
|
|
inc_dirs = []
|
|
--
|
|
2.13.5
|
|
|