44b170e104
Closes #2767 lsof compile breaks if CFLAGS overridden in 'make' command line which is the case since buildroot-2010.08. lsof has a partial fix for this already in the form of the 'LSOF_CFLAGS_OVERRIDE=1' configure option; however this only fixes the problem in the generation of the Makefile for liblsof. This patch does two things: it extends the 'LSOF_CFLAGS_OVERRIDE=1' configure option to also cover the main Makefile; it also patches lsof.mk to make use of the LSOF_CFLAGS_OVERRIDE option. Signed-off-by: Andy Gibbs <andyg1001@hotmail.co.uk> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
14 lines
437 B
Diff
14 lines
437 B
Diff
--- lsof_4.81/lsof_4.81_src/Configure 2008-10-21 18:21:45.000000000 +0200
|
|
+++ lsof_4.81/lsof_4.81_src/Configure 2010-11-03 14:00:00.000000000 +0100
|
|
@@ -5206,6 +5206,10 @@
|
|
cp $LSOF_MKFC ${LSOF_LIB}/$LSOF_LIBMKF
|
|
fi # }
|
|
cat ./dialects/$LSOF_DIALECT_DIR/$LSOF_REST >> $LSOF_MKFC
|
|
+if test "X$LSOF_CFLAGS_OVERRIDE" != "X" # {
|
|
+then
|
|
+ sed -i -e 's/^CFLAGS=/override CFLAGS=/' $LSOF_MKFC
|
|
+fi # }
|
|
if test "X$LSOF_LIB_NO" = "X" # {
|
|
then
|
|
|