5f5be8c552
This will fix build with sigrok-cli and python 3.8 Fixes: - http://autobuild.buildroot.org/results/4855d42545cbfeeec7529410acc84b61bc8790af Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
42 lines
1.9 KiB
Diff
42 lines
1.9 KiB
Diff
From afae4fa61ffd8dee62667e60f931e371061c7d7d Mon Sep 17 00:00:00 2001
|
|
From: Uwe Hermann <uwe@hermann-uwe.de>
|
|
Date: Tue, 12 Nov 2019 21:58:23 +0100
|
|
Subject: [PATCH] configure.ac: Add support for Python 3.8.
|
|
|
|
This fixes bug #1438.
|
|
[Retrieved from:
|
|
https://sigrok.org/gitweb/?p=libsigrokdecode.git;a=commit;h=afae4fa61ffd8dee62667e60f931e371061c7d7d]
|
|
Signed-off-by: Fabrice Fontaine <fontaine.fabrice@gmail.com>
|
|
---
|
|
configure.ac | 7 +++++--
|
|
1 file changed, 5 insertions(+), 2 deletions(-)
|
|
|
|
diff --git a/configure.ac b/configure.ac
|
|
index 772b984..d59e0be 100644
|
|
--- a/configure.ac
|
|
+++ b/configure.ac
|
|
@@ -89,15 +89,18 @@ SRD_PKGLIBS_TESTS=
|
|
SR_PKG_CHECK_SUMMARY([srd_pkglibs_summary])
|
|
|
|
# Python 3 is always needed.
|
|
+# Starting with Python 3.8 we need to check for "python-3.8-embed"
|
|
+# first, since usually only that variant will add "-lpython3.8".
|
|
+# https://docs.python.org/3/whatsnew/3.8.html#debug-build-uses-the-same-abi-as-release-build
|
|
SR_PKG_CHECK([python3], [SRD_PKGLIBS],
|
|
- [python3 >= 3.2], [python-3.7 >= 3.7], [python-3.6 >= 3.6], [python-3.5 >= 3.5], [python-3.4 >= 3.4], [python-3.3 >= 3.3], [python-3.2 >= 3.2])
|
|
+ [python-3.8-embed], [python-3.8 >= 3.8], [python-3.7 >= 3.7], [python-3.6 >= 3.6], [python-3.5 >= 3.5], [python-3.4 >= 3.4], [python-3.3 >= 3.3], [python-3.2 >= 3.2], [python3 >= 3.2])
|
|
AS_IF([test "x$sr_have_python3" = xno],
|
|
[AC_MSG_ERROR([Cannot find Python 3 development headers.])])
|
|
|
|
# We also need to find the name of the python3 executable (for 'make install').
|
|
# Some OSes call this python3, some call it python3.2, etc. etc.
|
|
AC_ARG_VAR([PYTHON3], [Python 3 interpreter])
|
|
-AC_CHECK_PROGS([PYTHON3], [python3.7 python3.6 python3.5 python3.4 python3.3 python3.2 python3])
|
|
+AC_CHECK_PROGS([PYTHON3], [python3.8 python3.7 python3.6 python3.5 python3.4 python3.3 python3.2 python3])
|
|
AS_IF([test "x$PYTHON3" = x],
|
|
[AC_MSG_ERROR([Cannot find Python 3 interpreter.])])
|
|
|
|
--
|
|
2.24.0.rc2
|
|
|