a2d7725e4d
The original aim of this patch was to fix static linking of btrfs-progs. In order to implement this in the form of patches that can potentially be upstreamed, this patch first bumps the btrfs-progs package to the latest upstream stable version. It then: - Reworks the existing documentation disabling patch in a form that can potentially be upstreamed. - Adds a patch to support static building of the btrfs-progs binaries. Both patches have been submitted upstream, see http://article.gmane.org/gmane.comp.file-systems.btrfs/38145. Fixes: http://autobuild.buildroot.org/results/ddc/ddcc70143ce2c2882894184e4ce195a11407e027/ Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
42 lines
1.3 KiB
Diff
42 lines
1.3 KiB
Diff
From 5e101a32087bbba18ebbcdf75faee3fff27f7168 Mon Sep 17 00:00:00 2001
|
|
From: Gustavo Zacarias <gustavo@zacarias.com.ar>
|
|
Date: Sat, 30 Aug 2014 14:42:00 +0200
|
|
Subject: [PATCH 1/2] Add support for DISABLE_DOCUMENTATION
|
|
|
|
This commit adds the support for a make variable named
|
|
"DISABLE_DOCUMENTATION", which allows to disable the build of the
|
|
documentation. This is useful in contexts where the tools needed to
|
|
build the documentation are not necessarily available.
|
|
|
|
Signed-off-by: Gustavo Zacarias <gustavo@zacarias.com.ar>
|
|
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
|
|
---
|
|
Makefile | 9 +++++++--
|
|
1 file changed, 7 insertions(+), 2 deletions(-)
|
|
|
|
diff --git a/Makefile b/Makefile
|
|
index e721e99..926885f 100644
|
|
--- a/Makefile
|
|
+++ b/Makefile
|
|
@@ -57,10 +57,15 @@ btrfs_image_libs = -lpthread
|
|
btrfs_fragments_libs = -lgd -lpng -ljpeg -lfreetype
|
|
|
|
SUBDIRS =
|
|
-BUILDDIRS = $(patsubst %,build-%,$(SUBDIRS)) build-Documentation
|
|
-INSTALLDIRS = $(patsubst %,install-%,$(SUBDIRS)) install-Documentation
|
|
+BUILDDIRS = $(patsubst %,build-%,$(SUBDIRS))
|
|
+INSTALLDIRS = $(patsubst %,install-%,$(SUBDIRS))
|
|
CLEANDIRS = $(patsubst %,clean-%,$(SUBDIRS))
|
|
|
|
+ifneq ($(DISABLE_DOCUMENTATION),1)
|
|
+BUILDDIRS += build-Documentation
|
|
+INSTALLDIRS += install-Documentation
|
|
+endif
|
|
+
|
|
.PHONY: $(SUBDIRS)
|
|
.PHONY: $(BUILDDIRS)
|
|
.PHONY: $(INSTALLDIRS)
|
|
--
|
|
2.0.0
|
|
|