6cc126f1bb
Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de> [Thomas: update comment in the .mk file about autoreconf.] Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
55 lines
1.8 KiB
Diff
55 lines
1.8 KiB
Diff
From f346045e0f63289909322a3264e69b967a911636 Mon Sep 17 00:00:00 2001
|
|
From: Alec Leamas <leamas.alec@gmail.com>
|
|
Date: Tue, 24 May 2016 19:56:09 +0200
|
|
Subject: [PATCH] Don't build commandir unless we have usb.h (#191).
|
|
|
|
Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
|
|
(backported from git master:
|
|
https://sourceforge.net/p/lirc/git/ci/f346045e0f63289909322a3264e69b967a911636/tree/plugins/Makefile.am?diff=4b26eb383291576b3f56820c6cec5f6a75814807)
|
|
---
|
|
plugins/Makefile.am | 14 +++++++++-----
|
|
1 file changed, 9 insertions(+), 5 deletions(-)
|
|
|
|
diff --git a/plugins/Makefile.am b/plugins/Makefile.am
|
|
index 3bd89ed..2116658 100644
|
|
--- a/plugins/Makefile.am
|
|
+++ b/plugins/Makefile.am
|
|
@@ -14,6 +14,7 @@ EXTRA_DIST = pluginlist.am make-pluginlist.sh
|
|
plugin_LTLIBRARIES =
|
|
|
|
if BUILD_USB
|
|
+
|
|
plugin_LTLIBRARIES += atilibusb.la
|
|
atilibusb_la_SOURCES = atilibusb.c
|
|
atilibusb_la_LDFLAGS = $(AM_LDFLAGS) @usb_libs@
|
|
@@ -33,6 +34,14 @@ plugin_LTLIBRARIES += srm7500libusb.la
|
|
srm7500libusb_la_SOURCES = srm7500libusb.c
|
|
srm7500libusb_la_LDFLAGS = $(AM_LDFLAGS) @usb_libs@
|
|
srm7500libusb_la_CFLAGS = $(AM_CFLAGS) $(LIBUSB_CFLAGS)
|
|
+
|
|
+if !BSD
|
|
+plugin_LTLIBRARIES += commandir.la
|
|
+commandir_la_SOURCES = commandir.c
|
|
+commandir_la_LDFLAGS = $(AM_LDFLAGS) @usb_libs@
|
|
+commandir_la_CFLAGS = $(AM_CFLAGS) $(LIBUSB_CFLAGS)
|
|
+endif
|
|
+
|
|
endif
|
|
|
|
if BUILD_FTDI
|
|
@@ -99,11 +108,6 @@ if !BSD
|
|
plugin_LTLIBRARIES += default.la
|
|
default_la_SOURCES = default.c
|
|
|
|
-plugin_LTLIBRARIES += commandir.la
|
|
-commandir_la_SOURCES = commandir.c
|
|
-commandir_la_LDFLAGS = $(AM_LDFLAGS) @usb_libs@
|
|
-commandir_la_CFLAGS = $(AM_CFLAGS) $(LIBUSB_CFLAGS)
|
|
-
|
|
plugin_LTLIBRARIES += hiddev.la
|
|
hiddev_la_SOURCES = hiddev.c
|
|
|
|
--
|
|
2.8.1
|
|
|