817938bb16
Cherry-picked from upstream. Fixes: http://autobuild.buildroot.net/results/fa7f7db861c342f4d189f74b983ae9d2751cf29b/ Signed-off-by: Paul Cercueil <paul.cercueil@analog.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
31 lines
864 B
Diff
31 lines
864 B
Diff
From 1bc450179a0819970261e6a29071756d09b71c5f Mon Sep 17 00:00:00 2001
|
|
From: Paul Cercueil <paul.cercueil@analog.com>
|
|
Date: Fri, 19 Aug 2016 09:00:58 +0200
|
|
Subject: [PATCH] CMake: Link with librt if found
|
|
|
|
This is required for older versions of glibc.
|
|
|
|
Signed-off-by: Paul Cercueil <paul.cercueil@analog.com>
|
|
---
|
|
CMakeLists.txt | 4 ++++
|
|
1 file changed, 4 insertions(+)
|
|
|
|
diff --git a/CMakeLists.txt b/CMakeLists.txt
|
|
index 2a339fe..3dd3520 100644
|
|
--- a/CMakeLists.txt
|
|
+++ b/CMakeLists.txt
|
|
@@ -113,6 +113,10 @@ add_definitions(-DLIBIIO_VERSION_GIT="${LIBIIO_VERSION_GIT}")
|
|
if(WITH_LOCAL_BACKEND)
|
|
add_definitions(-DLOCAL_BACKEND=1)
|
|
set(LIBIIO_CFILES ${LIBIIO_CFILES} local.c)
|
|
+
|
|
+ # Link with librt if present
|
|
+ find_library(LIBRT_LIBRARIES rt)
|
|
+ set(LIBS_TO_LINK ${LIBS_TO_LINK} ${LIBRT_LIBRARIES})
|
|
endif()
|
|
|
|
find_library(LIBUSB_LIBRARIES usb-1.0)
|
|
--
|
|
2.8.1
|
|
|