2455c89bab
This is mostly a mechanical bump, with a refresh of all the patches to accomodate the offsets, and some minor conflict resolution. Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
26 lines
971 B
Diff
26 lines
971 B
Diff
Use a symlink between python and pythonVERSION
|
|
|
|
By default, a hard link is used between /usr/bin/python and
|
|
/usr/bin/pythonVERSION. Using hard links for such things is fairly
|
|
uncommon, so let's make a symbolic link instead.
|
|
|
|
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
|
|
|
|
---
|
|
Makefile.pre.in | 2 +-
|
|
1 file changed, 1 insertion(+), 1 deletion(-)
|
|
|
|
Index: Python-2.7.2/Makefile.pre.in
|
|
===================================================================
|
|
--- Python-2.7.2.orig/Makefile.pre.in
|
|
+++ Python-2.7.2/Makefile.pre.in
|
|
@@ -796,7 +796,7 @@
|
|
then rm -f $(DESTDIR)$(BINDIR)/$(PYTHON); \
|
|
else true; \
|
|
fi
|
|
- (cd $(DESTDIR)$(BINDIR); $(LN) python$(VERSION)$(EXE) $(PYTHON))
|
|
+ (cd $(DESTDIR)$(BINDIR); $(LN) -s python$(VERSION)$(EXE) $(PYTHON))
|
|
-rm -f $(DESTDIR)$(BINDIR)/python-config
|
|
(cd $(DESTDIR)$(BINDIR); $(LN) -s python$(VERSION)-config python-config)
|
|
-test -d $(DESTDIR)$(LIBPC) || $(INSTALL) -d -m $(DIRMODE) $(DESTDIR)$(LIBPC)
|