2455c89bab
This is mostly a mechanical bump, with a refresh of all the patches to accomodate the offsets, and some minor conflict resolution. Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
27 lines
1003 B
Diff
27 lines
1003 B
Diff
Disable import check when cross-compiling
|
|
|
|
Once Python has compiled an extension (i.e some C code, potentially
|
|
linked to a library), it tries to import it. This cannot work in
|
|
cross-compilation mode, so we just disable this check.
|
|
|
|
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
|
|
---
|
|
setup.py | 4 ++++
|
|
1 file changed, 4 insertions(+)
|
|
|
|
Index: Python-2.7.2/setup.py
|
|
===================================================================
|
|
--- Python-2.7.2.orig/setup.py
|
|
+++ Python-2.7.2/setup.py
|
|
@@ -304,6 +304,10 @@
|
|
self.announce('WARNING: skipping import check for Cygwin-based "%s"'
|
|
% ext.name)
|
|
return
|
|
+ if os.environ.get('CROSS_COMPILING') == 'yes':
|
|
+ self.announce('WARNING: skipping import check for cross compiled "%s"'
|
|
+ % ext.name)
|
|
+ return
|
|
ext_filename = os.path.join(
|
|
self.build_lib,
|
|
self.get_ext_filename(self.get_ext_fullname(ext.name)))
|