6d3b4faca9
Adding -lpcre in LDFLAGS place the library before object files: gcc ... -lpcre -L.../sysroot/usr/lib -s -o ngrep ngrep.o -lpcap Makefile.in is patched to use @LIBS@ for adding -lpcre in the right place. Fixes: http://autobuild.buildroot.net/results/684/684a3bed28d13ef5e5156257aade3b9aff32f180 [Peter: fixup patch description] Signed-off-by: Romain Naour <romain.naour@openwide.fr> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
26 lines
555 B
Diff
26 lines
555 B
Diff
ngrep: fix static link with pcre
|
|
|
|
Libraries must be placed after object files.
|
|
|
|
Signed-off-by: Romain Naour <romain.naour@openwide.fr>
|
|
---
|
|
Makefile.in | 2 +-
|
|
1 file changed, 1 insertion(+), 1 deletion(-)
|
|
|
|
diff --git a/Makefile.in b/Makefile.in
|
|
index 2ae4506..761d7d9 100644
|
|
--- a/Makefile.in
|
|
+++ b/Makefile.in
|
|
@@ -11,7 +11,7 @@ CFLAGS=@CFLAGS@ -D@OS@ @DEFS@ @EXTRA_DEFINES@
|
|
INCLUDES=-I@srcdir@ @PCAP_INCLUDE@ @EXTRA_INCLUDES@
|
|
|
|
LDFLAGS=@LDFLAGS@ @PCAP_LINK@
|
|
-LIBS=-lpcap @EXTRA_LIBS@
|
|
+LIBS=@LIBS@ @EXTRA_LIBS@
|
|
|
|
STRIPFLAG=@STRIPFLAG@
|
|
|
|
--
|
|
1.8.1.4
|
|
|