03c4d57f1d
[Peter: s/python/python3/] Signed-off-by: Maxime Ripard <maxime.ripard@free-electrons.com> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
41 lines
1.7 KiB
Diff
41 lines
1.7 KiB
Diff
Do not generate .pyo files
|
|
|
|
By default, the Python installation byte-compiles all modules in two
|
|
forms: the normal bytecode (.pyc) and an optimized bytecode (.pyo).
|
|
|
|
According to
|
|
http://www.network-theory.co.uk/docs/pytut/CompiledPythonfiles.html,
|
|
the optimization do not do anything useful, and generating both the
|
|
"non-optimized" and "optimized" bytecode variants takes time.
|
|
|
|
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
|
|
---
|
|
Makefile.pre.in | 9 ---------
|
|
1 file changed, 9 deletions(-)
|
|
|
|
Index: Python-3.3.0/Makefile.pre.in
|
|
===================================================================
|
|
--- Python-3.3.0.orig/Makefile.pre.in
|
|
+++ Python-3.3.0/Makefile.pre.in
|
|
@@ -1082,20 +1082,11 @@
|
|
-d $(LIBDEST) -f \
|
|
-x 'bad_coding|badsyntax|site-packages|lib2to3/tests/data' \
|
|
$(DESTDIR)$(LIBDEST)
|
|
- -PYTHONPATH=$(DESTDIR)$(LIBDEST) $(RUNSHARED) \
|
|
- $(PYTHON_FOR_BUILD) -Wi -O $(DESTDIR)$(LIBDEST)/compileall.py \
|
|
- -d $(LIBDEST) -f \
|
|
- -x 'bad_coding|badsyntax|site-packages|lib2to3/tests/data' \
|
|
- $(DESTDIR)$(LIBDEST)
|
|
-PYTHONPATH=$(DESTDIR)$(LIBDEST) $(RUNSHARED) \
|
|
$(PYTHON_FOR_BUILD) -Wi $(DESTDIR)$(LIBDEST)/compileall.py \
|
|
-d $(LIBDEST)/site-packages -f \
|
|
-x badsyntax $(DESTDIR)$(LIBDEST)/site-packages
|
|
-PYTHONPATH=$(DESTDIR)$(LIBDEST) $(RUNSHARED) \
|
|
- $(PYTHON_FOR_BUILD) -Wi -O $(DESTDIR)$(LIBDEST)/compileall.py \
|
|
- -d $(LIBDEST)/site-packages -f \
|
|
- -x badsyntax $(DESTDIR)$(LIBDEST)/site-packages
|
|
- -PYTHONPATH=$(DESTDIR)$(LIBDEST) $(RUNSHARED) \
|
|
$(PYTHON_FOR_BUILD) -m lib2to3.pgen2.driver $(DESTDIR)$(LIBDEST)/lib2to3/Grammar.txt
|
|
-PYTHONPATH=$(DESTDIR)$(LIBDEST) $(RUNSHARED) \
|
|
$(PYTHON_FOR_BUILD) -m lib2to3.pgen2.driver $(DESTDIR)$(LIBDEST)/lib2to3/PatternGrammar.txt
|