03c4d57f1d
[Peter: s/python/python3/] Signed-off-by: Maxime Ripard <maxime.ripard@free-electrons.com> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
42 lines
1.5 KiB
Diff
42 lines
1.5 KiB
Diff
Tell setup.py the location of headers/libraries
|
|
|
|
Allow the libraries detection routine to look for headers and libs in
|
|
other directories than /usr/include or /usr/lib through the
|
|
environment variables PYTHON_MODULES_INCLUDE and PYTHON_MODULES_LIB.
|
|
|
|
We can then use it to look for libraries in the buildroot staging
|
|
directory.
|
|
|
|
Ported to python3.3 by Maxime Ripard <maxime.ripard@free-electrons.com> based
|
|
on the work by Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
|
|
|
|
Signed-off-by: Maxime Ripard <maxime.ripard@free-electrons.com>
|
|
---
|
|
setup.py | 13 +++++++++++++
|
|
1 file changed, 13 insertions(+)
|
|
|
|
Index: Python-3.3.0/setup.py
|
|
===================================================================
|
|
--- Python-3.3.0.orig/setup.py
|
|
+++ Python-3.3.0/setup.py
|
|
@@ -441,6 +441,19 @@
|
|
os.unlink(tmpfile)
|
|
|
|
def detect_modules(self):
|
|
+ try:
|
|
+ modules_include_dirs = os.environ["PYTHON_MODULES_INCLUDE"].split()
|
|
+ except KeyError:
|
|
+ modules_include_dirs = ['/usr/include']
|
|
+ try:
|
|
+ modules_lib_dirs = os.environ["PYTHON_MODULES_LIB"].split()
|
|
+ except KeyError:
|
|
+ modules_lib_dirs = ['/usr/lib']
|
|
+ for dir in modules_include_dirs:
|
|
+ add_dir_to_list(self.compiler.include_dirs, dir)
|
|
+ for dir in modules_lib_dirs:
|
|
+ add_dir_to_list(self.compiler.library_dirs, dir)
|
|
+
|
|
# Ensure that /usr/local is always used, but the local build
|
|
# directories (i.e. '.' and 'Include') must be first. See issue
|
|
# 10520.
|