4b3425c0bb
Pyhton 2.7.3 includes several security fixes. See: http://www.python.org/download/releases/2.7.3/ Also fixes the patch making sqlite optional and remove the symlink patch (which has been fixed upstream). Signed-off-by: Samuel Martin <s.martin49@gmail.com> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
89 lines
3.0 KiB
Diff
89 lines
3.0 KiB
Diff
Add an option to disable lib2to3
|
|
|
|
lib2to3 is a library to convert Python 2.x code to Python 3.x. As
|
|
such, it is probably not very useful on embedded system targets.
|
|
|
|
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
|
|
Signed-off-by: Samuel Martin <s.martin49@gmail.com>
|
|
|
|
---
|
|
Makefile.pre.in | 24 +++++++++++++++++-------
|
|
configure.in | 6 ++++++
|
|
setup.py | 5 +++--
|
|
3 files changed, 26 insertions(+), 9 deletions(-)
|
|
|
|
Index: Python-2.7.2/Makefile.pre.in
|
|
===================================================================
|
|
--- Python-2.7.2.orig/Makefile.pre.in
|
|
+++ Python-2.7.2/Makefile.pre.in
|
|
@@ -862,7 +862,6 @@
|
|
json \
|
|
sqlite3 \
|
|
logging bsddb csv importlib wsgiref \
|
|
- lib2to3 lib2to3/fixes lib2to3/pgen2 \
|
|
ctypes ctypes/macholib idlelib idlelib/Icons \
|
|
distutils distutils/command $(XMLLIBSUBDIRS) \
|
|
multiprocessing multiprocessing/dummy \
|
|
@@ -875,8 +874,7 @@
|
|
lib-tk/test/test_ttk test test/data \
|
|
test/cjkencodings test/decimaltestdata test/xmltestdata test/subprocessdata \
|
|
test/tracedmodules email/test email/test/data \
|
|
- json/tests sqlite3/test bsddb/test lib2to3/tests \
|
|
- lib2to3/tests/data lib2to3/tests/data/fixers lib2to3/tests/data/fixers/myfixes \
|
|
+ json/tests sqlite3/test bsddb/test \
|
|
ctypes/test distutils/tests unittest/test
|
|
endif
|
|
|
|
@@ -884,6 +882,16 @@
|
|
LIBSUBDIRS += pydoc_data
|
|
endif
|
|
|
|
+ifeq (@LIB2TO3@,yes)
|
|
+LIBSUBDIRS += lib2to3 lib2to3/fixes lib2to3/pgen2
|
|
+ifeq (@TEST_MODULES@,yes)
|
|
+LIBSUBDIRS += lib2to3/tests \
|
|
+ lib2to3/tests/data \
|
|
+ lib2to3/tests/data/fixers \
|
|
+ lib2to3/tests/data/fixers/myfixes
|
|
+endif
|
|
+endif
|
|
+
|
|
libinstall: build_all $(srcdir)/Lib/$(PLATDIR) $(srcdir)/Modules/xxmodule.c
|
|
@for i in $(SCRIPTDIR) $(LIBDEST); \
|
|
do \
|
|
Index: Python-2.7.2/configure.in
|
|
===================================================================
|
|
--- Python-2.7.2.orig/configure.in
|
|
+++ Python-2.7.2/configure.in
|
|
@@ -2419,6 +2419,12 @@
|
|
AS_HELP_STRING([--disable-test-modules], [disable test modules]),
|
|
[ TEST_MODULES="${enableval}" ], [ TEST_MODULES=yes ])
|
|
|
|
+AC_SUBST(LIB2TO3)
|
|
+
|
|
+AC_ARG_ENABLE(lib2to3,
|
|
+ AS_HELP_STRING([--disable-lib2to3], [disable lib2to3]),
|
|
+ [ LIB2TO3="${enableval}" ], [ LIB2TO3=yes ])
|
|
+
|
|
# Check for enable-ipv6
|
|
AH_TEMPLATE(ENABLE_IPV6, [Define if --enable-ipv6 is specified])
|
|
AC_MSG_CHECKING([if --enable-ipv6 is specified])
|
|
Index: Python-2.7.2/setup.py
|
|
===================================================================
|
|
--- Python-2.7.2.orig/setup.py
|
|
+++ Python-2.7.2/setup.py
|
|
@@ -2093,10 +2093,11 @@
|
|
import warnings
|
|
warnings.filterwarnings("ignore",category=DeprecationWarning)
|
|
|
|
- scripts = ['Tools/scripts/idle', 'Tools/scripts/2to3',
|
|
- 'Lib/smtpd.py']
|
|
+ scripts = ['Tools/scripts/idle', 'Lib/smtpd.py']
|
|
if not '--disable-pydoc' in sysconfig.get_config_var("CONFIG_ARGS"):
|
|
scripts += [ 'Tools/scripts/pydoc' ]
|
|
+ if not '--disable-lib2to3' in sysconfig.get_config_var("CONFIG_ARGS"):
|
|
+ scripts += [ 'Tools/scripts/2to3' ]
|
|
|
|
setup(# PyPI Metadata (PEP 301)
|
|
name = "Python",
|