4b3425c0bb
Pyhton 2.7.3 includes several security fixes. See: http://www.python.org/download/releases/2.7.3/ Also fixes the patch making sqlite optional and remove the symlink patch (which has been fixed upstream). Signed-off-by: Samuel Martin <s.martin49@gmail.com> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
79 lines
2.9 KiB
Diff
79 lines
2.9 KiB
Diff
Add an option to disable installation of test modules
|
|
|
|
The Python standard distribution comes with many test modules, that
|
|
are not necessarly useful on embedded targets.
|
|
|
|
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
|
|
Signed-off-by: Samuel Martin <s.martin49@gmail.com>
|
|
|
|
---
|
|
Makefile.pre.in | 40 +++++++++++++++++++++++++++-------------
|
|
configure.in | 6 ++++++
|
|
2 files changed, 33 insertions(+), 13 deletions(-)
|
|
|
|
Index: Python-2.7.2/Makefile.pre.in
|
|
===================================================================
|
|
--- Python-2.7.2.orig/Makefile.pre.in
|
|
+++ Python-2.7.2/Makefile.pre.in
|
|
@@ -856,23 +856,30 @@
|
|
plat-mac/lib-scriptpackages/SystemEvents \
|
|
plat-mac/lib-scriptpackages/Terminal
|
|
PLATMACPATH=:plat-mac:plat-mac/lib-scriptpackages
|
|
-LIBSUBDIRS= lib-tk lib-tk/test lib-tk/test/test_tkinter \
|
|
- lib-tk/test/test_ttk site-packages test test/data \
|
|
- test/cjkencodings test/decimaltestdata test/xmltestdata test/subprocessdata \
|
|
- test/tracedmodules \
|
|
+LIBSUBDIRS= lib-tk site-packages \
|
|
encodings compiler hotshot \
|
|
- email email/mime email/test email/test/data \
|
|
- json json/tests \
|
|
- sqlite3 sqlite3/test \
|
|
- logging bsddb bsddb/test csv importlib wsgiref \
|
|
- lib2to3 lib2to3/fixes lib2to3/pgen2 lib2to3/tests \
|
|
- lib2to3/tests/data lib2to3/tests/data/fixers lib2to3/tests/data/fixers/myfixes \
|
|
- ctypes ctypes/test ctypes/macholib idlelib idlelib/Icons \
|
|
- distutils distutils/command distutils/tests $(XMLLIBSUBDIRS) \
|
|
+ email email/mime \
|
|
+ json \
|
|
+ sqlite3 \
|
|
+ logging bsddb csv importlib wsgiref \
|
|
+ lib2to3 lib2to3/fixes lib2to3/pgen2 \
|
|
+ ctypes ctypes/macholib idlelib idlelib/Icons \
|
|
+ distutils distutils/command $(XMLLIBSUBDIRS) \
|
|
multiprocessing multiprocessing/dummy \
|
|
- unittest unittest/test \
|
|
+ unittest \
|
|
lib-old \
|
|
curses pydoc_data $(MACHDEPS)
|
|
+
|
|
+ifeq (@TEST_MODULES@,yes)
|
|
+LIBSUBDIRS += lib-tk/test lib-tk/test/test_tkinter \
|
|
+ lib-tk/test/test_ttk test test/data \
|
|
+ test/cjkencodings test/decimaltestdata test/xmltestdata test/subprocessdata \
|
|
+ test/tracedmodules email/test email/test/data \
|
|
+ json/tests sqlite3/test bsddb/test lib2to3/tests \
|
|
+ lib2to3/tests/data lib2to3/tests/data/fixers lib2to3/tests/data/fixers/myfixes \
|
|
+ ctypes/test distutils/tests unittest/test
|
|
+endif
|
|
+
|
|
libinstall: build_all $(srcdir)/Lib/$(PLATDIR) $(srcdir)/Modules/xxmodule.c
|
|
@for i in $(SCRIPTDIR) $(LIBDEST); \
|
|
do \
|
|
Index: Python-2.7.2/configure.in
|
|
===================================================================
|
|
--- Python-2.7.2.orig/configure.in
|
|
+++ Python-2.7.2/configure.in
|
|
@@ -2408,6 +2408,12 @@
|
|
fi
|
|
|
|
|
|
+AC_SUBST(TEST_MODULES)
|
|
+
|
|
+AC_ARG_ENABLE(test-modules,
|
|
+ AS_HELP_STRING([--disable-test-modules], [disable test modules]),
|
|
+ [ TEST_MODULES="${enableval}" ], [ TEST_MODULES=yes ])
|
|
+
|
|
# Check for enable-ipv6
|
|
AH_TEMPLATE(ENABLE_IPV6, [Define if --enable-ipv6 is specified])
|
|
AC_MSG_CHECKING([if --enable-ipv6 is specified])
|