b18dca0df8
This commit removes the version selection for the busybox package. Busybox is very well maintained, and bugs are typically fixed in a timely fashion. Moreover, regressions are fairly unlikely in this very stable and well-tested tool. Therefore, there isn't a very compelling reason to have a version selection for Busybox since we don't accept such a version selection for the vast majority of other packages, unless there is a strong reason to do so. Consequently, this commit: * Removes the 1.19.4, 1.20.2 and 1.21.1 Busybox versions, patches and default configuration file. * Moves the 1.22.1 patches from package/busybox/1.22.1 to just package/busybox/ like all other packages. * Renames the default 1.22.1 configuration file to just busybox.config. * Adapts the busybox.mk makefile to encode the current version to use. * Adds appropriate options to Config.in.legacy. However, even though the BR2_BUSYBOX_VERSION_1_22_X is removed, we don't add a Config.in.legacy option for it, since it would cause a legacy warning for virtually *all* users as most people are currently using 1.22.x. Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
16 lines
615 B
Diff
16 lines
615 B
Diff
--- busybox-1.22.1/networking/nc_bloaty.c
|
|
+++ busybox-1.22.1-nc/networking/nc_bloaty.c
|
|
@@ -175,9 +175,9 @@ enum {
|
|
OPT_w = (1 << 5),
|
|
OPT_l = (1 << 6) * ENABLE_NC_SERVER,
|
|
OPT_k = (1 << 7) * ENABLE_NC_SERVER,
|
|
- OPT_i = (1 << (7+2*ENABLE_NC_SERVER)) * ENABLE_NC_EXTRA,
|
|
- OPT_o = (1 << (8+2*ENABLE_NC_SERVER)) * ENABLE_NC_EXTRA,
|
|
- OPT_z = (1 << (9+2*ENABLE_NC_SERVER)) * ENABLE_NC_EXTRA,
|
|
+ OPT_i = (1 << (6+2*ENABLE_NC_SERVER)) * ENABLE_NC_EXTRA,
|
|
+ OPT_o = (1 << (7+2*ENABLE_NC_SERVER)) * ENABLE_NC_EXTRA,
|
|
+ OPT_z = (1 << (8+2*ENABLE_NC_SERVER)) * ENABLE_NC_EXTRA,
|
|
};
|
|
|
|
#define o_nflag (option_mask32 & OPT_n)
|