kumquat-buildroot/package/gpm/0003-src-Makefile.in-Really-install-unversioned-solibrary.patch
Ricardo Martincoski 39424c2899 package: remove numbered subject from patches
As reported by check-package (by calling it directly):
generate your patches with 'git format-patch -N'

Change all affected files using this command:
$ sed 's,^\(Subject: *\[PATCH\)[^]]*,\1,g' \
    -i $(find * -name '*.patch' -type f)

Signed-off-by: Ricardo Martincoski <ricardo.martincoski@gmail.com>
Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
2021-12-11 20:48:58 +01:00

32 lines
1.2 KiB
Diff

From 445be05fba32c512fd87a0c98b4e9936629ef95e Mon Sep 17 00:00:00 2001
From: Bernd Kuhls <bernd.kuhls@t-online.de>
Date: Sat, 20 Feb 2016 17:59:52 +0100
Subject: [PATCH] src/Makefile.in: Really install unversioned solibrary
This commit is a follow-up to
https://github.com/telmich/gpm/commit/06b00d53d8bd513ad5d262dc94a016c6fbf2d3aa
which created libgpm.so but failed to include it in the install target.
Patch sent upstream: https://github.com/telmich/gpm/pull/11
Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
---
src/Makefile.in | 1 +
1 file changed, 1 insertion(+)
diff --git a/src/Makefile.in b/src/Makefile.in
index 7e9e2ef..bca226f 100644
--- a/src/Makefile.in
+++ b/src/Makefile.in
@@ -115,6 +115,7 @@ install: check
if test "x@SHLIB@" != "x" ; then \
$(INSTALL_DATA) -m 755 lib/libgpm.so.@abi_full@ $(libdir)/libgpm.so.@abi_full@ ; \
cd $(libdir) && $(LN_S) -f libgpm.so.@abi_full@ libgpm.so.@abi_lev@ ; \
+ cd $(libdir) && $(LN_S) -f libgpm.so.@abi_full@ libgpm.so ; \
echo "WARNING: We installed a lib, you should now call ldconfig" ; \
echo "f.i.: ldconfig -n -l $(libdir)/libgpm.so.@abi_full@" ; \
echo "Or to update everything just type ldconfig" ; \
--
2.7.0