736c4c1655
FreeRADIUS is an open source server which implements a protocol for remote user Authorization, Authentication and Accounting. There are many modules. All modules without dependencies are enabled. The modules with a dependency that we have are automatically enabled if the dependency is enabled. Modules with dependencies we don't support are explicitly disabled. The configure script always looks in host directories for libraries, so it is essential to explicitly disable everything that is not actually provided. Signed-off-by: David GOUARIN <dgouarin@gmail.com> Signed-off-by: Kalpesh Panchal <kalpesh.panchal@rockwellcollins.com> Signed-off-by: Matt Weber <matthew.weber@collins.com> [Arnout: - remove second patch, superseded by other patches; - add upstream links to patches; - add more patches to avoid looking in host directories; - explicitly add dependency on !static inherited from talloc (redundant with glibc, but future-safe); - simplify Config.in comment; - check hash with PGP signature; - add conf opts for runtime paths; - add conf opts to disable unsupported modules; - add more optional dependencies; - enable/disable all modules that use a dependency; - search defaults file in /etc/default, not /etc/sysconfig. ] Signed-off-by: Arnout Vandecappelle (Essensium/Mind) <arnout@mind.be>
43 lines
1.8 KiB
Diff
43 lines
1.8 KiB
Diff
From d6c1da041da77902a06d10bf03ef454468921801 Mon Sep 17 00:00:00 2001
|
|
From: Changqing Li <changqing.li@windriver.com>
|
|
Date: Tue, 24 Jul 2018 15:03:39 +0800
|
|
Subject: [PATCH] configure.ac: allow cross-compilation
|
|
|
|
The checking OpenSSL library and header version consistency will
|
|
always fail in cross compiling, skip the check and give a warning
|
|
instead for cross compiling.
|
|
|
|
Upstream-Status: Inappropriate[embedded specific]
|
|
|
|
Signed-off-by: Jackie Huang <jackie.huang@windriver.com>
|
|
Signed-off-by: Yi Zhao <yi.zhao@windriver.com>
|
|
|
|
update to new version 3.0.17 to fix patch warning
|
|
Signed-off-by: Changqing Li <changqing.li@windriver.com>
|
|
|
|
Fetch from: http://cgit.openembedded.org/meta-openembedded/tree/meta-networking/recipes-connectivity/freeradius/files
|
|
Signed-off-by: David Gouarin <david.gouarin@thalesgroup.com>
|
|
Signed-off-by: Matt Weber <matthew.weber@rockwellcollins.com>
|
|
Upstream: https://github.com/FreeRADIUS/freeradius-server/pull/4632
|
|
---
|
|
src/modules/rlm_krb5/configure.ac | 3 ++-
|
|
1 file changed, 2 insertions(+), 1 deletion(-)
|
|
|
|
diff --git a/src/modules/rlm_krb5/configure.ac b/src/modules/rlm_krb5/configure.ac
|
|
index efc9f29d7f..98a97e438a 100644
|
|
--- a/src/modules/rlm_krb5/configure.ac
|
|
+++ b/src/modules/rlm_krb5/configure.ac
|
|
@@ -137,7 +137,8 @@ if test x$with_[]modname != xno; then
|
|
FR_SMART_CHECK_LIB(krb5, krb5_is_thread_safe)
|
|
if test "x$ac_cv_lib_krb5_krb5_is_thread_safe" = xyes; then
|
|
AC_RUN_IFELSE([AC_LANG_PROGRAM([[#include <krb5.h>]], [[return krb5_is_thread_safe() ? 0 : 1]])],
|
|
- [krb5threadsafe="-DKRB5_IS_THREAD_SAFE"], [AC_MSG_WARN([[libkrb5 is not threadsafe]])])
|
|
+ [krb5threadsafe="-DKRB5_IS_THREAD_SAFE"], [AC_MSG_WARN([[libkrb5 is not threadsafe]])],
|
|
+ [AC_MSG_WARN(cross compiling: not checking)])
|
|
fi
|
|
else
|
|
krb5threadsafe=""
|
|
--
|
|
2.17.1
|
|
|