9a52f40e58
Upstream does not provide hashes anymore, replace with self-computed sha256 hash. Removed patches applied upstream, renumbered remaining patches: 0001-allow-building-of-the-shared-library-to-be-suppressed.patch https://git.kernel.org/pub/scm/linux/kernel/git/dhowells/keyutils.git/commit/?id=a4deb71ddc05e951c8be8d46615beed9d408a5c8 0004-Makefile-for-buildroot.patch https://git.kernel.org/pub/scm/linux/kernel/git/dhowells/keyutils.git/commit/?id=d83b9b827c6c4bc2377dfa073cf5c837b87465e8 Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
21 lines
778 B
Diff
21 lines
778 B
Diff
Makefile: fix install rule
|
|
|
|
Do not link the .so with an absolute path, otherwise it may point to
|
|
the host library.
|
|
|
|
Based on the former patch by Yann E. MORIN.
|
|
|
|
Signed-off-by: Vicente Olivert Riera <vincent.riera@imgtec.com>
|
|
|
|
--- keyutils-1.5.9/Makefile.orig 2014-09-22 16:13:41.593562765 +0100
|
|
+++ keyutils-1.5.9/Makefile 2014-09-22 16:14:05.377963952 +0100
|
|
@@ -168,7 +168,7 @@ ifeq ($(NO_SOLIB),0)
|
|
$(INSTALL) -D $(LIBNAME) $(DESTDIR)$(LIBDIR)/$(LIBNAME)
|
|
$(LNS) $(LIBNAME) $(DESTDIR)$(LIBDIR)/$(SONAME)
|
|
mkdir -p $(DESTDIR)$(USRLIBDIR)
|
|
- $(LNS) $(LIBDIR)/$(SONAME) $(DESTDIR)$(USRLIBDIR)/$(DEVELLIB)
|
|
+ $(LNS) $(SONAME) $(DESTDIR)$(USRLIBDIR)/$(DEVELLIB)
|
|
endif
|
|
$(INSTALL) -D keyctl $(DESTDIR)$(BINDIR)/keyctl
|
|
$(INSTALL) -D request-key $(DESTDIR)$(SBINDIR)/request-key
|