kumquat-buildroot/package/x11r7/xserver_xorg-server/0001-include-misc.h-fix-uClibc-build.patch
Bernd Kuhls d9185c6ba3 package/x11r7/xserver_xorg-server: bump version to 21.1.1
Removed patches which were applied upstream:

0001-modesettings-needs-dri2.patch
9c81b8f5b5

0003-hw-xwayland-Makefile.am-fix-build-without-glx.patch
836f93de99

0004-hw-xfree86-common-xf86Init.c-fix-build-without-glx.patch
49456e0a37

0005-Fix-segfault-on-probing-a-non-PCI-platform-device-on.patch
e50c85f4eb

0006-compiler.h-don-t-define-inb-outb-and-friends-on-mips.patch
0148a15da1

Renumbered remaining patch.

Removed xwayland options:
4ee66f574a

Added dependency to xlib_libxcvt:
a4ab57cb74

Release notes:
https://lists.x.org/archives/xorg-announce/2021-October/003115.html
https://lists.x.org/archives/xorg-announce/2021-November/003116.html

Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
2021-11-13 15:37:57 +01:00

32 lines
787 B
Diff

From 2e8fca00f5bdb02f2f59aaa428d1e9d808ab0e86 Mon Sep 17 00:00:00 2001
From: Bernd Kuhls <bernd.kuhls@t-online.de>
Date: Sat, 16 Jun 2018 19:20:16 +0200
Subject: [PATCH] include/misc.h: fix uClibc build
A similar fix was used for Dovecot:
https://www.dovecot.org/list/dovecot/2017-November/110019.html
Signed-off-by: Bernd Kuhls <bernd.kuhls@t-online.de>
---
include/misc.h | 4 ++++
1 file changed, 4 insertions(+)
diff --git a/include/misc.h b/include/misc.h
index 14920c3c3..390e52b60 100644
--- a/include/misc.h
+++ b/include/misc.h
@@ -185,6 +185,10 @@ typedef struct _xReq *xReqPtr;
#endif
#endif
+#undef bswap_16
+#undef bswap_32
+#undef bswap_64
+
/**
* Calculate the number of bytes needed to hold bits.
* @param bits The minimum number of bits needed.
--
2.17.1