kumquat-buildroot/package/python-gpiozero/python-gpiozero.mk
Peter Seiderer bfee0a7e9b package/python-gpiozero: bump version to 1.6.2
- update license file hash:
  @@ -1,3 +1,5 @@
  +SPDX-License-Identifier: BSD-3-Clause
  +

- add setuptools runtime dependency, fixes:

	$ pinout -r a020d3 -m
	Traceback (most recent call last):
	  File "/usr/bin/pinout", line 6, in <module>
	    from pkg_resources import load_entry_point
	ModuleNotFoundError: No module named 'pkg_resources'

For details see [1].

[1] https://gpiozero.readthedocs.io/en/stable/changelog.html

Signed-off-by: Peter Seiderer <ps.report@gmx.net>
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
2021-04-22 21:34:49 +02:00

14 lines
451 B
Makefile

################################################################################
#
# python-gpiozero
#
################################################################################
PYTHON_GPIOZERO_VERSION = 1.6.2
PYTHON_GPIOZERO_SITE = $(call github,gpiozero,gpiozero,v$(PYTHON_GPIOZERO_VERSION))
PYTHON_GPIOZERO_LICENSE = BSD-3-Clause
PYTHON_GPIOZERO_LICENSE_FILES = LICENSE.rst
PYTHON_GPIOZERO_SETUP_TYPE = setuptools
$(eval $(python-package))