c016a48b99
With BR2_PREFER_STATIC_LIB, libcap fails to build: http://autobuild.buildroot.net/results/619bceb3491ecd2ed4e1ae552fdb237a0ed2fa47/build-end.log This is due to the fact that it still tries to build a shared library. This commit fixes that by adding a patch that makes libcap provide install-shared/install-static targets. We also now only build the $(@D)/libcap subdirectory, so removing the build of the progs subdirectory is no longer needed. [Peter: fixup description] Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Reviewed-by: Samuel Martin <s.martin49@gmail.com> Reviewed-by: "Yann E. MORIN" <yann.morin.1998@free.fr> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
31 lines
981 B
Diff
31 lines
981 B
Diff
libcap: split install into install-shared/install-static
|
|
|
|
In order to support static only builds, split the install target into
|
|
install-shared and install-static targets.
|
|
|
|
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
|
|
|
|
Index: b/libcap/Makefile
|
|
===================================================================
|
|
--- a/libcap/Makefile
|
|
+++ b/libcap/Makefile
|
|
@@ -60,11 +60,17 @@
|
|
cap_text.o: cap_text.c $(USE_GPERF_OUTPUT) $(INCLS)
|
|
$(CC) $(CFLAGS) $(IPATH) $(INCLUDE_GPERF_OUTPUT) -c $< -o $@
|
|
|
|
-install: all
|
|
+install: install-shared install-static
|
|
+
|
|
+install-common:
|
|
mkdir -p -m 0755 $(INCDIR)/sys
|
|
install -m 0644 include/sys/capability.h $(INCDIR)/sys
|
|
mkdir -p -m 0755 $(LIBDIR)
|
|
+
|
|
+install-static: install-common
|
|
install -m 0644 $(STALIBNAME) $(LIBDIR)/$(STALIBNAME)
|
|
+
|
|
+install-shared: install-common
|
|
install -m 0755 $(MINLIBNAME) $(LIBDIR)/$(MINLIBNAME)
|
|
ln -sf $(MINLIBNAME) $(LIBDIR)/$(MAJLIBNAME)
|
|
ln -sf $(MAJLIBNAME) $(LIBDIR)/$(LIBNAME)
|