37451a9dc5
The vpnc upstream project has not made any tarball release since many years, but they have continued to update their Subversion repository. A Github repository synced with the Subversion repository now exists at https://github.com/ndpgroup/vpnc, which is more practical to generate patches and submit pull requests. For this reason, we move to using this Github repository as the new source for the vpnc package. The specific commit that we use corresponds to version 0.5.3 exactly. All patches are re-formatted using Git. Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Reviewed-by: "Yann E. MORIN" <yann.morin.1998@free.fr> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
82 lines
2.6 KiB
Diff
82 lines
2.6 KiB
Diff
From fd7e584bd28bd541464f8cb6cc72e76de2347640 Mon Sep 17 00:00:00 2001
|
|
From: Samuel Martin <s.martin49@gmail.com>
|
|
Date: Mon, 8 Feb 2016 23:02:45 +0100
|
|
Subject: [PATCH] Misc. Makefile cleanup and fix the VERSION definition.
|
|
|
|
Signed-off-by: Samuel Martin <s.martin49@gmail.com>
|
|
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
|
|
---
|
|
Makefile | 40 +++++++++++++++++++---------------------
|
|
1 file changed, 19 insertions(+), 21 deletions(-)
|
|
|
|
diff --git a/Makefile b/Makefile
|
|
index 9b96d83..1ca6459 100644
|
|
--- a/Makefile
|
|
+++ b/Makefile
|
|
@@ -19,21 +19,19 @@
|
|
#
|
|
# $Id$
|
|
|
|
-DESTDIR=
|
|
-PREFIX=/usr/local
|
|
-ETCDIR=/etc/vpnc
|
|
-BINDIR=$(PREFIX)/bin
|
|
-SBINDIR=$(PREFIX)/sbin
|
|
-MANDIR=$(PREFIX)/share/man
|
|
-DOCDIR=$(PREFIX)/share/doc/vpnc
|
|
-
|
|
-SRCS = sysdep.c vpnc-debug.c isakmp-pkt.c tunip.c config.c dh.c math_group.c supp.c decrypt-utils.c
|
|
-BINS = vpnc cisco-decrypt
|
|
-OBJS = $(addsuffix .o,$(basename $(SRCS)))
|
|
+DESTDIR =
|
|
+PREFIX ?= /usr/local
|
|
+ETCDIR = /etc/vpnc
|
|
+BINDIR = $(PREFIX)/bin
|
|
+SBINDIR = $(PREFIX)/sbin
|
|
+MANDIR = $(PREFIX)/share/man
|
|
+DOCDIR = $(PREFIX)/share/doc/vpnc
|
|
+
|
|
+SRCS = sysdep.c vpnc-debug.c isakmp-pkt.c tunip.c config.c dh.c math_group.c supp.c decrypt-utils.c
|
|
+BINS = vpnc cisco-decrypt
|
|
+OBJS = $(addsuffix .o,$(basename $(SRCS)))
|
|
BINOBJS = $(addsuffix .o,$(BINS))
|
|
BINSRCS = $(addsuffix .c,$(BINS))
|
|
-VERSION := $(shell sh mk-version)
|
|
-RELEASE_VERSION := $(shell cat VERSION)
|
|
|
|
# The license of vpnc (Gpl >= 2) is quite likely incompatible with the
|
|
# openssl license. Openssl is currently used to provide certificate
|
|
@@ -50,13 +48,13 @@ RELEASE_VERSION := $(shell cat VERSION)
|
|
#OPENSSL_GPL_VIOLATION = -DOPENSSL_GPL_VIOLATION
|
|
#OPENSSLLIBS = -lcrypto
|
|
|
|
-CC=gcc
|
|
-CFLAGS ?= -O3 -g
|
|
-CFLAGS += -W -Wall -Wmissing-declarations -Wwrite-strings
|
|
-CFLAGS += $(shell libgcrypt-config --cflags)
|
|
-CPPFLAGS += -DVERSION=\"$(VERSION)\" $(OPENSSL_GPL_VIOLATION)
|
|
-LDFLAGS ?= -g
|
|
-LDFLAGS += $(shell libgcrypt-config --libs) $(OPENSSLLIBS)
|
|
+CC ?= gcc
|
|
+CFLAGS ?= -O3 -g
|
|
+CFLAGS += -W -Wall -Wmissing-declarations -Wwrite-strings
|
|
+CFLAGS += $(shell libgcrypt-config --cflags)
|
|
+CPPFLAGS += $(OPENSSL_GPL_VIOLATION)
|
|
+LDFLAGS ?= -g
|
|
+LDFLAGS += $(shell libgcrypt-config --libs) $(OPENSSLLIBS)
|
|
|
|
ifeq ($(shell uname -s), SunOS)
|
|
LDFLAGS += -lnsl -lresolv -lsocket
|
|
@@ -81,7 +79,7 @@ cisco-decrypt : cisco-decrypt.o decrypt-utils.o
|
|
$(CC) -o $@ $^ $(LDFLAGS)
|
|
|
|
.depend: $(SRCS) $(BINSRCS)
|
|
- $(CC) -MM $(SRCS) $(BINSRCS) $(CFLAGS) $(CPPFLAGS) > $@
|
|
+ $(CC) -MM $(SRCS) $(BINSRCS) $(CPPFLAGS) $(CFLAGS) > $@
|
|
|
|
vpnc-debug.c vpnc-debug.h : isakmp.h enum2debug.pl
|
|
LC_ALL=C perl -w ./enum2debug.pl isakmp.h >vpnc-debug.c 2>vpnc-debug.h
|
|
--
|
|
2.6.4
|
|
|