9be273e024
- Remove upstream patch [1]. - evas-modules option removed since all evas-modules are now built shared. [2] - Make sure that mono is disabled [3]. - gstreamer support removed from emotion & evas [4]. - emotion-loaders-disabler & emotion-generic-loaders-disabler removed [5]. - Add openjpeg dependency for jp2k evas loader [6] otherwise the build system fail when only libjpeg.so is provided (jpeg-turbo or libjpeg). - Update COMPLIANCE file hash due to esacpe library removal [7]. - Update COPYING file hash due to new csharp,cxx libraries and esacpe,emotion removal [8]. - Remove bullet dependency from recommended option for efl [9]. - Add new patches to fix build with "Unknown variable" issue with meson. - Fix Evas_Engine_GL_Drm.h include path. [1] https://git.enlightenment.org/core/efl.git/commit/?id=a2afcfc872c29bd2c4a60fdafbc655c90f938d1e https://git.enlightenment.org/core/efl.git/commit/?id=c245b576aad09ac5faeb800de7f7c4fef87c6363 [2] https://git.enlightenment.org/core/efl.git/commit/?id=6d8e39a6425e721eb40e0cb1e67f1cbf5b223cc0 [3] https://git.enlightenment.org/core/efl.git/commit/?id=17a81bee4a53891e44a165a14ca20027f9aa0824 [4] https://git.enlightenment.org/core/efl.git/commit/?id=b8dc80c144fec54a521987535c57b995748ccece [5] https://git.enlightenment.org/core/efl.git/commit/?id=075bab83c4288b5de20f6acfc6b0459656ea85e0 [6] https://git.enlightenment.org/core/efl.git/commit/?id=8ec6e28b7cc568a8bb636de90b2dd10f19db2be3 [7] https://git.enlightenment.org/core/efl.git/commit/?id=f3d9b8ee703621cfbb52a03d346335148318af7a [8] https://git.enlightenment.org/core/efl.git/commit/?id=40a980174b7e29e6946f7425bd7a238ae45900f8 https://git.enlightenment.org/core/efl.git/commit/?id=a3ade15d5a45e7d564b7c1304f561af9c4203991 https://git.enlightenment.org/core/efl.git/commit/?id=31da42a0503556a59c190efcb0a79331e828bf6c [9] https://git.enlightenment.org/core/efl.git/commit/?id=523a64d2265c13a82ba73022d10919f0e392bab2 See: https://www.enlightenment.org/news/efl-1.24.0 https://www.enlightenment.org/news/efl-1.24.1 https://www.enlightenment.org/news/efl-1.24.2 https://www.enlightenment.org/news/efl-1.24.3 Signed-off-by: Romain Naour <romain.naour@gmail.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@bootlin.com>
37 lines
1.3 KiB
Diff
37 lines
1.3 KiB
Diff
From f6b8b53fdd1cb63219f61e783479bf8d221649b3 Mon Sep 17 00:00:00 2001
|
|
From: Romain Naour <romain.naour@gmail.com>
|
|
Date: Sat, 1 Aug 2020 02:25:47 +0200
|
|
Subject: [PATCH] ecore_evas/engines/drm/meson.build: use "gl_deps" as engine
|
|
dependencies
|
|
|
|
Meson trigger an error since "engine_gl_drm" variable doesn't exist.
|
|
|
|
src/modules/ecore_evas/engines/drm/meson.build:10:2: ERROR: Unknown variable "engine_gl_drm".
|
|
|
|
Instead use "gl_deps" as engine dependencies.
|
|
|
|
Upstream status:
|
|
https://sourceforge.net/p/enlightenment/mailman/message/37075016/
|
|
|
|
Signed-off-by: Romain Naour <romain.naour@gmail.com>
|
|
---
|
|
src/modules/ecore_evas/engines/drm/meson.build | 2 +-
|
|
1 file changed, 1 insertion(+), 1 deletion(-)
|
|
|
|
diff --git a/src/modules/ecore_evas/engines/drm/meson.build b/src/modules/ecore_evas/engines/drm/meson.build
|
|
index 584cc56159..de645f1093 100644
|
|
--- a/src/modules/ecore_evas/engines/drm/meson.build
|
|
+++ b/src/modules/ecore_evas/engines/drm/meson.build
|
|
@@ -7,7 +7,7 @@ engine_deps = [ecore_drm2, ecore_input, eeze, elput, libdrm, engine_drm]
|
|
|
|
if get_option('opengl') != 'none'
|
|
config_h.set('BUILD_ECORE_EVAS_GL_DRM', '1')
|
|
- engine_deps += [engine_gl_drm]
|
|
+ engine_deps += [gl_deps]
|
|
endif
|
|
|
|
engine_include_dir += include_directories(join_paths('..', '..', '..', 'evas', 'engines', 'drm'))
|
|
--
|
|
2.25.4
|
|
|