298cd8eaa2
Autogenerated from rename-patch.py (http://patchwork.ozlabs.org/patch/403345) Signed-off-by: Samuel Martin <s.martin49@gmail.com> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
36 lines
1.4 KiB
Diff
36 lines
1.4 KiB
Diff
[PATCH] Don't include config.h when building helpers using the native compiler
|
||
|
||
config.h contains settings for the cross compiler (most importantly
|
||
32/64bit versions of functions), so don't include it when calling the
|
||
native compiler to build the helpers.
|
||
|
||
Otherwise we get build errors like:
|
||
|
||
/usr/bin/gcc -include ../config.h -DBSD=1 -DSHELL -DIFS_BROKEN -g -O2 -Wall -o mkinit mkinit.c
|
||
In file included from /usr/include/sys/stat.h:107,
|
||
from /usr/include/fcntl.h:38,
|
||
from mkinit.c:50:
|
||
/usr/include/bits/stat.h:117: error: redefinition of ‘struct stat’
|
||
In file included from /usr/include/fcntl.h:38,
|
||
from mkinit.c:50:
|
||
/usr/include/sys/stat.h:504: error: redefinition of ‘stat’
|
||
/usr/include/sys/stat.h:455: note: previous definition of ‘stat’ was here
|
||
|
||
Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
|
||
---
|
||
src/Makefile.in | 1 -
|
||
1 file changed, 1 deletion(-)
|
||
|
||
Index: dash-0.5.5.1/src/Makefile.in
|
||
===================================================================
|
||
--- dash-0.5.5.1.orig/src/Makefile.in
|
||
+++ dash-0.5.5.1/src/Makefile.in
|
||
@@ -165,7 +165,6 @@ COMMON_CPPFLAGS = \
|
||
AM_CFLAGS = $(COMMON_CFLAGS)
|
||
AM_CPPFLAGS = $(COMMON_CPPFLAGS)
|
||
AM_CFLAGS_FOR_BUILD = -g -O2 $(COMMON_CFLAGS)
|
||
-AM_CPPFLAGS_FOR_BUILD = $(COMMON_CPPFLAGS)
|
||
COMPILE_FOR_BUILD = \
|
||
$(CC_FOR_BUILD) $(AM_CPPFLAGS_FOR_BUILD) $(CPPFLAGS_FOR_BUILD) \
|
||
$(AM_CFLAGS_FOR_BUILD) $(CFLAGS_FOR_BUILD)
|