f066ed70cd
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com> Signed-off-by: Peter Korsgaard <jacmet@sunsite.dk>
44 lines
1.8 KiB
Diff
44 lines
1.8 KiB
Diff
Link against libintl if needed
|
|
|
|
When built against a C library that has locale support, but for which
|
|
intl support is provided by an external libintl library, psmisc
|
|
forgets to link against this library, even though the configure script
|
|
properly checks that.
|
|
|
|
This patch therefore ensure that we link against libintl when needed,
|
|
thanks to the @INTLLIBS@ variable provided by the configure script.
|
|
|
|
We do not modify the Makefile.am file, because autoreconfiguring this
|
|
package doesn't work: because of its usage of gettext, it wants to run
|
|
the "autopoint" program, which itself depends on CVS being installed,
|
|
for some strange reasons. That's the reason why we fall back to the
|
|
hacky solution of modifying the Makefile.in file.
|
|
|
|
It replaces a hack which was mistakenly removed by commit
|
|
542fbe8520c981f9c96705a57e4263f34f2ab2e6.
|
|
|
|
Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
|
|
|
|
Index: psmisc-22.13/src/Makefile.in
|
|
===================================================================
|
|
--- psmisc-22.13.orig/src/Makefile.in 2011-05-21 15:12:17.212412293 +0200
|
|
+++ psmisc-22.13/src/Makefile.in 2011-05-21 16:08:50.220326032 +0200
|
|
@@ -216,12 +216,15 @@
|
|
$(am__append_4) $(am__append_6) $(am__append_8) \
|
|
$(am__append_10)
|
|
fuser_SOURCES = fuser.c comm.h signals.c signals.h i18n.h fuser.h
|
|
+fuser_LDADD = @INTLLIBS@
|
|
killall_SOURCES = killall.c comm.h signals.c signals.h i18n.h
|
|
-killall_LDADD = @SELINUX_LIB@
|
|
+killall_LDADD = @SELINUX_LIB@ @INTLLIBS@
|
|
peekfd_SOURCES = peekfd.c
|
|
+peekfd_LDADD = @INTLLIBS@
|
|
pstree_SOURCES = pstree.c comm.h i18n.h
|
|
-pstree_LDADD = @TERMCAP_LIB@ @SELINUX_LIB@
|
|
+pstree_LDADD = @TERMCAP_LIB@ @SELINUX_LIB@ @INTLLIBS@
|
|
prtstat_SOURCES = prtstat.c prtstat.h
|
|
+prtstat_LDADD = @INTLLIBS@
|
|
BUILT_SOURCES = signames.h
|
|
EXTRA_DIST = signames.c
|
|
CLEANFILES = signames.h
|