kumquat-buildroot/package/pipewire-media-session/0001-meson-remove-session-managers-option-check.patch
James Hilliard 51f30f47cd package/pipewire-media-session: new package
The pipewire-media-session has been moved into a separate package
which pipewire attempts to download via meson wraps if
session-managers are enabled, since we don't support meson wraps
we need to disable session-managers in the pipewire package and
create a new pipewire-media-session package.

We also need to add a patch removing an invalid session-managers
option check from pipewire-media-session.

There is an alsa with-module-sets option in pipewire-media-session,
however at the moment alsa is an unconditional dependency so
we need to always enable it and select alsa-lib.

Note: it was previously an option of the pipewire package, named
media-session, so the symbol was BR2_PACKAGE_PIPEWIRE_MEDIA_SESSION.
Now it is a package name pipewire-media-session, so the symbol is still
BR2_PACKAGE_PIPEWIRE_MEDIA_SESSION. So there is no legacy entry needed,
and users previously using that option will now get the package. Sneaky.

Signed-off-by: James Hilliard <james.hilliard1@gmail.com>
[yann.morin.1998@free.fr:
  - extend commit log with legacy handling
  - first unconditional CONF_OPTS uses =, not +=; fits on one line
  - slight reorder in variables assignments
]
Signed-off-by: Yann E. MORIN <yann.morin.1998@free.fr>
2021-11-10 23:00:06 +01:00

37 lines
1.5 KiB
Diff

From 1923c97fbd0b3d8cacdb72386886f860c818bccf Mon Sep 17 00:00:00 2001
From: James Hilliard <james.hilliard1@gmail.com>
Date: Wed, 10 Nov 2021 08:54:06 -0700
Subject: [PATCH] meson: remove session-managers option check.
This option no longer exists and causes a build failure if building
with the systemd system service enabled.
Signed-off-by: James Hilliard <james.hilliard1@gmail.com>
[Upstream status:
https://gitlab.freedesktop.org/pipewire/media-session/-/merge_requests/24]
---
systemd/system/meson.build | 10 ++++------
1 file changed, 4 insertions(+), 6 deletions(-)
diff --git a/systemd/system/meson.build b/systemd/system/meson.build
index ab0d49064..0e9885b0f 100644
--- a/systemd/system/meson.build
+++ b/systemd/system/meson.build
@@ -4,9 +4,7 @@ systemd_system_services_dir = systemd.get_variable(pkgconfig: 'systemdsystemunit
systemd_config = configuration_data()
systemd_config.set('PW_MEDIA_SESSION_BINARY', media_session_bindir / 'pipewire-media-session')
-if get_option('session-managers').contains('media-session')
- configure_file(input : 'pipewire-media-session.service.in',
- output : 'pipewire-media-session.service',
- configuration : systemd_config,
- install_dir : systemd_system_services_dir)
-endif
+configure_file(input : 'pipewire-media-session.service.in',
+ output : 'pipewire-media-session.service',
+ configuration : systemd_config,
+ install_dir : systemd_system_services_dir)
--
2.25.1