814a9c32ae
Fixes compatibility with glibc 2.27. Fixes: http://autobuild.buildroot.net/results/bd7/bd7e1af33e6e937c75b44c7c9ab991d2b10f2931/ http://autobuild.buildroot.net/results/58b/58b59b74f6a138b51206f24481f7268104f0a052/ Signed-off-by: Baruch Siach <baruch@tkos.co.il> Signed-off-by: Peter Korsgaard <peter@korsgaard.com>
36 lines
1.2 KiB
Diff
36 lines
1.2 KiB
Diff
From 770902a0a29fb4ac62358f7eacb3a83d0d9af1c7 Mon Sep 17 00:00:00 2001
|
|
From: Vicente Olivert Riera <Vincent.Riera@imgtec.com>
|
|
Date: Wed, 25 Nov 2015 10:50:00 +0000
|
|
Subject: [PATCH] mdrestore: do not do dynamic linking of libtool libraries
|
|
|
|
As explained in commit ece49daeff1a3cad765e106d678c608925c9d768, use
|
|
-static-libtool-libs instead of -static to allow fallback to the dynamic
|
|
linking for libuuid only. Otherwise the build will fail like this:
|
|
|
|
ld: attempted static link of dynamic object `/usr/lib/libuuid.so'
|
|
|
|
Signed-off-by: Vicente Olivert Riera <Vincent.Riera@imgtec.com>
|
|
[Sent upstream: https://www.spinics.net/lists/xfs/msg36149.html]
|
|
[baruch: update for v4.15.1]
|
|
Signed-off-by: Baruch Siach <baruch@tkos.co.il>
|
|
---
|
|
mdrestore/Makefile | 2 +-
|
|
1 file changed, 1 insertion(+), 1 deletion(-)
|
|
|
|
diff --git a/mdrestore/Makefile b/mdrestore/Makefile
|
|
index 136ae716d691..75ff1bad78e9 100644
|
|
--- a/mdrestore/Makefile
|
|
+++ b/mdrestore/Makefile
|
|
@@ -10,7 +10,7 @@ CFILES = xfs_mdrestore.c
|
|
|
|
LLDLIBS = $(LIBXFS) $(LIBFROG) $(LIBRT) $(LIBPTHREAD) $(LIBUUID)
|
|
LTDEPENDENCIES = $(LIBXFS) $(LIBFROG)
|
|
-LLDFLAGS = -static
|
|
+LLDFLAGS = -static-libtool-libs
|
|
|
|
default: depend $(LTCOMMAND)
|
|
|
|
--
|
|
2.16.1
|
|
|