kumquat-buildroot/package/wayland/0002-meson-only-require-cpp-for-tests.patch
Adrian Perez de Castro fbde3a6c95 package/wayland: bump to version 1.19.0
Update wayland to version 1.19.0, which mostly includes bug fixes and is
the minimum version required by wlroots 0.13.0

Patch "0001-build-add-option-to-disable-tests.patch" is updated as an
actual backport from upstream. Since upstream has migrated to meson, and
we've already switched too, drop the autostuff hunks.

Patch "0002-meson-do-not-check-for-c.patch" is replaced by a newer one,
"0002-meson-only-require-cpp-for-tests.patch" which was accepted by
upstream as an improved version of it.

Signed-off-by: Adrian Perez de Castro <aperez@igalia.com>
[yann.morin.1998@free.fr:
  - do actual backports of upstream patches now they've been merged
  - consequently, drop the legacy autostuff hunks from first patch
]
Signed-off-by: Yann E. MORIN <yann.morin.1998@free.fr>
2021-05-16 15:15:27 +02:00

60 lines
1.4 KiB
Diff

From 4c2105312379b62dc84f6eaaf26e2ab293d51b92 Mon Sep 17 00:00:00 2001
From: James Hilliard <james.hilliard1@gmail.com>
Date: Fri, 16 Apr 2021 02:32:38 -0600
Subject: [PATCH] meson: only require cpp for tests
Signed-off-by: James Hilliard <james.hilliard1@gmail.com>
[Upstream status:
https://gitlab.freedesktop.org/wayland/wayland/-/merge_requests/130]
Signed-off-by: Adrian Perez de Castro <aperez@igalia.com>
[yann.morin.1998@free.fr: backport from upstream]
Signed-off-by: Yann E. MORIN <yann.morin.1998@free.fr>
---
meson.build | 2 +-
tests/meson.build | 16 +++++++++-------
2 files changed, 10 insertions(+), 8 deletions(-)
diff --git a/meson.build b/meson.build
index 12b4641..cdb66bc 100644
--- a/meson.build
+++ b/meson.build
@@ -1,5 +1,5 @@
project(
- 'wayland', 'c', 'cpp',
+ 'wayland', 'c',
version: '1.19.0',
license: 'MIT',
meson_version: '>= 0.52.1',
diff --git a/tests/meson.build b/tests/meson.build
index a32ac50..2e11af4 100644
--- a/tests/meson.build
+++ b/tests/meson.build
@@ -64,15 +64,17 @@ executable(
dependencies: test_runner_dep
)
-test(
- 'cpp-compile-test',
- executable(
+if add_languages('cpp')
+ test(
'cpp-compile-test',
- 'cpp-compile-test.cpp',
- wayland_server_protocol_h,
- include_directories: src_inc
+ executable(
+ 'cpp-compile-test',
+ 'cpp-compile-test.cpp',
+ wayland_server_protocol_h,
+ include_directories: src_inc
+ )
)
-)
+endif
sed_path = find_program('sed').path()
--
2.31.1