1c5cc29e32
Signed-off-by: Johan Oudinet <johan.oudinet@gmail.com> Signed-off-by: Thomas Petazzoni <thomas.petazzoni@free-electrons.com>
77 lines
1.9 KiB
Diff
77 lines
1.9 KiB
Diff
Description: remove make targets for deps
|
|
Without this patch, dependencies would be downloaded and compiled
|
|
using rebar at build time.
|
|
Author: Philipp Huebner <debalance@debian.org>
|
|
|
|
Index: ejabberd/Makefile.in
|
|
===================================================================
|
|
diff --git a/Makefile.in b/Makefile.in
|
|
index 8dd6bf5..b9d783a 100644
|
|
--- a/Makefile.in
|
|
+++ b/Makefile.in
|
|
@@ -77,26 +77,11 @@ else
|
|
INIT_USER=$(INSTALLUSER)
|
|
endif
|
|
|
|
-all: deps src
|
|
+all: src
|
|
|
|
-deps: deps/.got
|
|
-
|
|
-deps/.got:
|
|
- rm -rf deps/.got
|
|
- rm -rf deps/.built
|
|
- $(REBAR) get-deps && :> deps/.got
|
|
-
|
|
-deps/.built: deps/.got
|
|
- $(REBAR) compile && :> deps/.built
|
|
-
|
|
-src: deps/.built
|
|
+src:
|
|
$(REBAR) skip_deps=true compile
|
|
|
|
-update:
|
|
- rm -rf deps/.got
|
|
- rm -rf deps/.built
|
|
- $(REBAR) update-deps && :> deps/.got
|
|
-
|
|
xref: all
|
|
$(REBAR) skip_deps=true xref
|
|
|
|
@@ -129,13 +114,10 @@ endef
|
|
|
|
$(foreach file,$(DEPS_FILES_FILTERED) $(MAIN_FILES),$(eval $(call COPY_template,$(file))))
|
|
|
|
-$(call TO_DEST,$(MAIN_DIRS) $(DEPS_DIRS)):
|
|
+$(call TO_DEST,$(MAIN_DIRS)):
|
|
$(INSTALL) -d $@
|
|
|
|
-$(call TO_DEST,deps/p1_pam/priv/bin/epam): $(LIBDIR)/%: deps/% $(call TO_DEST,deps/p1_pam/priv/bin/)
|
|
- $(INSTALL) -m 750 $(O_USER) $< $@
|
|
-
|
|
-copy-files: $(call TO_DEST,$(DEPS_FILES) $(MAIN_FILES))
|
|
+copy-files: $(call TO_DEST,$(MAIN_FILES))
|
|
|
|
install: all copy-files
|
|
#
|
|
@@ -172,10 +154,6 @@ install: all copy-files
|
|
-e "s*@installuser@*$(INIT_USER)*" ejabberd.init.template \
|
|
> ejabberd.init
|
|
chmod 755 ejabberd.init
|
|
- # Install Elixir and Elixir dependancies
|
|
- -$(INSTALL) -m 644 deps/*/lib/*/ebin/*.app $(BEAMDIR)
|
|
- -$(INSTALL) -m 644 deps/*/lib/*/ebin/*.beam $(BEAMDIR)
|
|
- rm -f $(BEAMDIR)/configure.beam
|
|
#
|
|
# Binary C programs
|
|
$(INSTALL) -d $(PBINDIR)
|
|
@@ -266,8 +244,6 @@ TAGS:
|
|
|
|
Makefile: Makefile.in
|
|
|
|
-deps := $(wildcard deps/*/ebin)
|
|
-
|
|
dialyzer/erlang.plt:
|
|
@mkdir -p dialyzer
|
|
@dialyzer --build_plt --output_plt dialyzer/erlang.plt \
|